OpenELEC Forum
OpenELEC PVR Build - PVR Backend - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: PVR + LIVE TV (https://forum.openelec.tv/forumdisplay.php?fid=38)
+--- Thread: OpenELEC PVR Build - PVR Backend (/showthread.php?tid=11663)

Pages: 1 2 3


Re: OpenELEC PVR Build - PVR Backend - michael7oliver - 10-05-2011

Hi Gujs,

Sorry to keep this post going but I was hoping you might be able to clarify something for me. Will the build you pointed me to automatically update or do I need to manually update it to RC7?


Aw: OpenELEC PVR Build - PVR Backend - Mettbrot - 11-08-2011

Hi there,

i recently tried one of those gujs pvr builds (pvr-ppa-odk54). ANd i have this strange problem:
I've activated everything: tvheadend HTSP CLient, Live TV functionality in XBMC settings, tvheadend service (in this order).

After enabling Live TV in XBMC settings it told me "No PVR Add-on enabled" If i click OK i am directed to the PVR addon page where the tvheadend HTSP CLient is activated.

I rebooted several times and everytime at startup i get this "No PVR Add-on enabled" error.
When i try to disable live TV in XBMC settings i get it too, but it does not disable...

PS: Maybe this is interesting: When i tried 'tvheadend' in console via ssh it says:
Code:
tvheadend: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory
in usr/lib/ there is realy no libcrypto.so.0.9.8 file... only libcrypt.so.1.0.0


Re: Aw: OpenELEC PVR Build - PVR Backend - Linuxxx - 11-08-2011

Mettbrot post=15929 Wrote:Hi there,

i recently tried one of those gujs pvr builds (pvr-ppa-odk54). ANd i have this strange problem:
I've activated everything: tvheadend HTSP CLient, Live TV functionality in XBMC settings, tvheadend service (in this order).

After enabling Live TV in XBMC settings it told me "No PVR Add-on enabled" If i click OK i am directed to the PVR addon page where the tvheadend HTSP CLient is activated.

I rebooted several times and everytime at startup i get this "No PVR Add-on enabled" error.
When i try to disable live TV in XBMC settings i get it too, but it does not disable...

PS: Maybe this is interesting: When i tried 'tvheadend' in console via ssh it says:
Code:
tvheadend: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory
in /lib/ there is realy no libcrypto.so.0.9.8 file... only libcrypt.so.1


I had the same error as you and installed in same order, but when i tried:

  1. Activate tvheadend HTSP Client
  2. Activate tvheadend service
  3. Activate Live TV

I got no more error. I don't know if it is a real solution or if i was just lucky. And i had to do it after a clean install because i could not deactivate the Live TV feature. Same as you.


Aw: OpenELEC PVR Build - PVR Backend - Mettbrot - 11-08-2011

Hi thanks for your answer. Which build have you tried? Mine is the last pvr odk54 and there seems to be a problem with tvheadend anyway because this libcrypto file is missing.

I was able to deactivate Live TV via guisettings.xml but it does not work either...


Re: Aw: OpenELEC PVR Build - PVR Backend - Linuxxx - 11-08-2011

I used odk48


Re: OpenELEC PVR Build - PVR Backend - m-i-k-e-e - 11-08-2011

Hi,

it's been said somewhere on the forum that the latest build from gujs (54) as tvheadend broken because of libcrypto not being compiled against gujs source (or something like that).
So your best bet is to use build 53 and specify
Code:
<skin>skin.confluence</skin>
in the
Code:
<lookandfeel>
section in the
Code:
/storage/.xbmc/userdata/guisettings.xml
, you will get black screen otherwise (it's been also suggested somewhere on the forum).
I'm using this build (53) and everything seems fine.

Bye


Re: OpenELEC PVR Build - PVR Backend - derNeue - 11-08-2011

Hi,

i've tried now the new odk54 from gujs. (OpenELEC_PVR-ION.x86_64-devel-20111104174618-r8988.tar.bz2)

Think it works.
There was an Linking error from the Webserver:

Code:
23:37:28 T:140696927016704 WARNING: FillBuffer: curl failed with code 22
23:37:28 T:140696927016704 ERROR: CFileCurl::CReadState::Open, didn't get any data from stream.
23:37:28 T:140696927016704 ERROR: DeleteFile - cant delete file </storage/.xbmc/addons/packages/service.multimedia.hts-tvheadend-1.90.0.zip>. trying lower case </storage/.xbmc/addons/packages/service.multimedia.hts-tvheadend-1.90.0.zip>

openelec was searching in (for ION 64 Bit)
http://addons.openelec.tv/1.90/ION/x86_64
for tvheadend, but the package exists in:
http://gujs.openelec.tv/build/addons/1.90/ION/x86_64/service.multimedia.hts-tvheadend/

I have downloaded the zip manually and have extracted it on Desktop.
Then copy it via samba it in the music folder (for example).
and copy it with ssh into the add-on directory from xbmc
Code:
cp -R /storage/music/service.multimedia.hts-tvheadend /storage/.xbmc/addons

Now i see the version git-ba5fe2a in the tvheadend gui.
I think your tvheadend service is not updated, because the link is broken. Try it manually. Think it works, because the new tvheadend version is using libcrypto.so.1.0.0.

Code:
/usr/lib/libcrypto.so
/usr/lib/libcrypto.so.1.0.0

you can find both files with this command:
Code:
find / -name libcrypto.so*
Think it exists and odk54 will work Smile

Here you can browse and download tvheadend for your platform:
Code:
http://gujs.openelec.tv/build/addons/1.90/

Try it! Think it works Smile

Yeeeha! Awesome openelec guys! B)


Re: OpenELEC PVR Build - PVR Backend - Bitcrusher - 11-08-2011

Ha! That actually worked. Can't believe it was as simple as copying it over after all I tried. Thanks for your solution :laugh:


Re: OpenELEC PVR Build - PVR Backend - squareeyes - 11-20-2011

I have inadvertently enabled Live TV but my server is not ready yet to connect to.
When I power on the OpenElec box or try to disable Live TV i get the errors:
Webserver failed to start

No PVR add-on enabled.. The PVR manager has been enabled without any enabled PVR add-on. Enable at least one add-on in order to use the PVR functionality.
Sometimes the box locks up for several minutes before normal operation is restored.


Re: OpenELEC PVR Build - PVR Backend - fbartels - 11-21-2011

@squareeyes

Gujis already posted a couple time that this has been fixed in the Opdenkamp Source repositories and that he will provide a newer build in the coming days.