OpenELEC Forum
How to setup audio output on ION330 - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: How to setup audio output on ION330 (/showthread.php?tid=13477)

Pages: 1 2 3


How to setup audio output on ION330 - alda - 10-21-2011

I have ION 330 based HTPC. I want ask how to setup audio, to get sound from HDMI when I'm navigating in menu, but during movie playback I need to have possibility set audio output HDMI / Analog5.1.

Thanks for help

Alda


Re: How to setup audio output on ION330 - Veldom - 10-24-2011

You could try this:

1 - Install Nano via Openelec Addons
2 - Access via SSh (user:root pass:openelec)
3 - Create/edit the file --> /storage/.config/asound.conf
4 - Write the following code

pcm.!default {
type plug
slave {
pcm "hdmi"
}

5 - Save the file & exit
6 - Reboot
7 - In Settings - System - Audio, make the following configuration:

Audio output = Analog
Speaker configuration = 5.1
Audio output device = HDMI
Custom audio device =
Passthrough output device = HDMI
Custom passthrough device =

8- Reboot

Hope this works!


Re: How to setup audio output on ION330 - alda - 10-25-2011

Thank you, I will try.
But please tell me how it will work : During menu navigation sound will go out from HDMI and during playback ?
HDMI or Analog or Both ?

Thanks

Alda


Re: How to setup audio output on ION330 - therio - 10-25-2011

So you want:

Menu sounds: HDMI
Audio from movies, music and all others: Analog or HDMI

The best option is to use Veldoms solution. This will send menu-sounds over HDMI and audio from movies, music and all others also over HDMI. If you want to change to analog for audio from movies, music and all others, just change the settings inside XBMC. As the menu-sounds are routed with the asound, I think they still keep working over HDMI, while the analog is selected for all other audio.


Re: How to setup audio output on ION330 - alda - 10-25-2011

Hi, thanks

I will test it.

Alda


Re: How to setup audio output on ION330 - alda - 10-30-2011

Hi,
one problem with analog output :

In the file /storage/.config/asound.conf I have :

pcm.!default {
type plug
slave {
pcm "hdmi"
}

to have sound from HDMI during main menu navigation.
And XBMC output I have set to analog 5.1.

With this setup I have sound from HDMI during menu navigation and analog 5.1 during movie playback, but when I start music, sound goes out from HDMI.
Why ? What to change to get also sound analog 5.1 ?

Thanks

Alda


Re: How to setup audio output on ION330 - MdMa - 11-02-2011

See this thread..
http://openelec.tv/forum/14-general-help-and-support/12261-multichannel-audio-over-pcm

Mainly Maxwell's and TR909's posts.

Basically use Maxwell's script and substitute hw:0,9 with hw:0,3 and you will get navigational sounds.

FLAC and TrueHD audio will still be messed up though.

EDIT: I am a little confused..

Why are you selecting Analog output? How is your ION330 connected to your TV (what type of cable(s))? Do you have an AVR/Amp?


Re: How to setup audio output on ION330 - alda - 11-02-2011

I have ION330 connected to tv with HDMI, but tv can play only steteo (two speakers).

Alda


Re: How to setup audio output on ION330 - MdMa - 11-02-2011

So then:

Audio Output: Digital

Speaker Configuration: 2.0

Dobly Digital & DTS Capable Receiver: Disabled/Un-highlighted

Audio Output Device: HDMI

Passthrough Output Device: None (I'm guessing)

Downmix Multi-channel Audio to Stereo: Enabled/Highlighted


Re: How to setup audio output on ION330 - alda - 11-02-2011

Sorry, maybe you don't understand my problem ( I think my English isn't good ).

What I want :
Multichannel 5.1 analog ( PCM ) output to three jacks which I have on back side of my ION330 PC during movie and music playing
and
HDMI output directly to TV during navigation in main menu.

What I did :
To get HDMI sound I added to /storage/.config/asound.conf this:

pcm.!default {
type plug
slave {
pcm "hdmi"
}

And It's ok, I have HDMI sound during menu navigating.

To get Multichannel 5.1 analog ( PCM ) output during movie and music playing, I changed XBMC audio setup to :

Audio Output: Analog

Speaker Configuration: 5.1

Dobly Digital & DTS Capable Receiver: Disabled/Un-highlighted

Audio Output Device: Default

Passthrough Output Device: None (I'm guessing)

Downmix Multi-channel Audio to Stereo: Disabled/Un-highlighted



And It's working for movie playing ( I have Multichannel 5.1 analog ( PCM ) output ), but when I start music ( mp3 playing ) sound goes out from HDMI - and I think it's xbmc bug or problem of player which is used for music playing ( if is different from player for movie playing ) because this player isn't looking on XBMC setup, but is looking to asound.conf.

Alda