OpenELEC Forum
KEY_PVR won't map. - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: KODI (https://forum.openelec.tv/forumdisplay.php?fid=32)
+--- Thread: KEY_PVR won't map. (/showthread.php?tid=25091)



KEY_PVR won't map. - SOLVED. - wdog118 - 02-05-2012

I have tried, for the life of me, EVERYTHING I can think of to get my KEY_PVR button to map in openelec but nothing will make it work.

When I ssh into the system and use the 'irw' function the key is recognized as 16e KEY_PVR. So I know the system recognizes the button. But when I assign it to a function in lircmap.xml and the remote.xml it does nothing.

Right now this is what I have it as.

Lircmap.xml
Code:
<lircmap>
<remote device="mceusb">
<recordedtv>KEY_PVR</recordedtv>
</remote>
</lircmap>

remote.xml
Code:
<keymap>
<global>
<remote>
<recordedtv>XBMC.ActivateWindow(Favourites)</recordedtv>
</remote>
</global>
<keymap>

I have tired different words and different key combos. No dice. The lircmap.xml is in the /storage/.xbmc/userdata. And the remote.xml is in /storage/.xbmc/userdata/keymaps.

What am I doing wrong here?


Re: KEY_PVR won't map. - ancalex - 02-05-2012

Hi
With irw maybe the KEY_PVR is recognized but it is mapped in an .evmap file?
eventlircd uses evmap files (in /etc/eventlircd.d)for mapping keys and this mapped keys will be then used in a Lircmap.xml
I don't know what kind of remote you have, this is important because if your remote is using (for example) 03_0755_2626.evmap then the line where KEY_PVR mapping is defined is
KEY_PVR = KEY_TV # PVR
so in your Lircmap.xml for that key to be active you must use KEY_TV (in this particular case).
Regards


Re: KEY_PVR won't map. - Terratec - 02-05-2012

can you try this section in lircmap?
Code:
<remote device="linux-input-layer">

My KEY_PVR is working there.


Re: KEY_PVR won't map. - wdog118 - 02-05-2012

I have a Hauppauge 1069 remote. http://wiki.linuxmce.org/index.php/File:MCE-Remote-2-v1069.jpg

I looked at all the evmaps. It could either be 03_0bc7_0006 or 03_0755_2626.

I tried using KEY_PVR = KEY_TV and KEY_PVR = KEY_KPENTER.

Neither one worked... Idk.


Re: KEY_PVR won't map. - joeythelips - 02-06-2012

I had a similar issue - with the same key.

Is irw reporting your remote as "mceusb"? You need to put exactly what irw identifies as your device.
In my case it was "devinput" rather than "mceusb". Once I used that, I was able to map the key.


Re: KEY_PVR won't map. - wdog118 - 02-06-2012

How do I know what irw sees my device as?


Re: KEY_PVR won't map. - ancalex - 02-06-2012

When you fire up irw an push butoons you will see something like this
Code:
6c 0 KEY_DOWN devinput
the last word is the device.


Re: KEY_PVR won't map. - joeythelips - 02-06-2012

wdog118 post=25130 Wrote:How do I know what irw sees my device as?

See previous post. In my case it's:

Code:
root ~ # irw
17b 0 KEY_VCR devinput
17b 0 KEY_VCR_UP devinput



Re: KEY_PVR won't map. - wdog118 - 02-06-2012

root ~ # irw
16e 0 KEY_PVR devinput
16e 0 KEY_PVR_UP devinput

IT WORKED!

I changed Lircmap.xml from <remote device="mceusb"> to <remote device="devinput">.

It solved my problem the KEY_PVR button now works.

Thanks for the help guys. Problem Solved.