OpenELEC Forum
Random crackling sounds on ALC892 - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: Random crackling sounds on ALC892 (/showthread.php?tid=27474)



Random crackling sounds on ALC892 - arthiev - 03-04-2012

Hi

I can't manage to get rid of random crackling sounds while playing mp3s or movies.

My rig :
i3 2105
Asrock motherboard with ALC892 for audio
1.0.2 Intel version of OpenELEC

The sound goes to TV via HDMI, then goes to the stereo system via optical.
So does sound from Adsl Tv and ps3, and neither crackles ...

Has anyone encountered this problem ?


Re: Random crackling sounds on ALC892 - therio - 03-04-2012

Crackling could be anything, especially when routing between different devices. Have you checked the optical cable and changed it for another one? Have you tried other audio formats than mp3 (movies can also contain mp3) to sort that out?


Re: Random crackling sounds on ALC892 - arthiev - 03-05-2012

As I said, the optical cable works fine with Dsl tv and ps3 for years ...

I tried a few minutes ago, the sound crackled with the stereo system ; then I put the sound via the tv speakers out, no problem ; then again with the stereo system, no problem at all ... with the same audio file.

I'll try to buy another optical cable in a few days.

I don't really know if crackling is the appropriate word for what I hear, but my english isn't good enough to find another one. And I don't have what it takes to record the sound ...


Re: Random crackling sounds on ALC892 - therio - 03-05-2012

Well I think to know want you meant and I'm also not native-english speaking Wink
But about the problem, another thing you could try (experimental, don't know if it will do anything different) is to set the audio settings to analog. Leave all other settings as they are now, it will only change the way how it will decode the sound, not the routing. With analog, it will stream your audio as plain PCM, doing all the decoding through XBMC. Maybe it changes anything...
About opticals, it can last a lifetime, but can break with just one bad move.


Re: Random crackling sounds on ALC892 - arthiev - 03-24-2012

Hi

Didn't answer before because I had to buy a new optical cable ... it arrived today and didn't change anything.

I tried to go analog ... and that's when I realized I was already analog ...
I did a aplay -l with putty, and here's my list :


**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

When I first started OpenELEC, I had no sound at all ;
I had to go with plughw:0,8 for both audio settings, and when I tried plughw:1,8,
it said it failed to initialize audio devices, or something like that ...

How come I can't use digital at all ?


Re: Random crackling sounds on ALC892 - rskadk - 03-28-2012

I think i have the same problems as you! I seems like there may be some serious driver problems for people using optical passthrough in OpenELEC :/

My thread is here:

http://openelec.tv/forum/68-audio/29554-sound-problems-in-openelec-not-in-xbmcubuntu


Random crackling sounds on ALC892 - birday - 03-11-2013

up
same problem here. is there a solution?