OpenELEC Forum
External drive name not being recognised + TV shows scanning incorrectly - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: STORAGE (https://forum.openelec.tv/forumdisplay.php?fid=60)
+--- Thread: External drive name not being recognised + TV shows scanning incorrectly (/showthread.php?tid=28872)



External drive name not being recognised + TV shows scanning incorrectly - juice690 - 03-21-2012

This is an odd one. A few days ago I defragmented an external usb drive as it was running a little slow etc...

The drive is 2TB split into equal 1TB partitions. The Name of the drives are XBMC 1TB 4 & XBMC 1TB 5. Before the defrag, both partitions, and their names were recognised when plugged into my openelec acer revo.

After the defrag, both partitions mount without a hitch, but instead of drive names, they both show up as 931.4 GB Drive (viewed from Video > Files,). Obviously that has a knock on effect to my library, and my Sabnzdb, as the source name has changed. If I access my Revo using ssh from my mac, and go to root > media, or var > media, I see my list of the external usb drives (four of them) listed exactly like this:-

6C8C-0904 < Unsure what that is, but it's an empty directory
1884795d-a7ed-3451-aa8b-2331f9829c36 < This is infact the Drive named XBMC 1TB 5
a5138c2e-1f53-3d7b-a46c-92f2ee47413d < And this one is XBMC 1TB 4
XBMC 1TB
XBMC 1TB 2
XBMC 1TB 3
XBMC 1TB 5 < Shows up, but it is a folder, containing a single empty folder in it titled 'TV'. I've tried to delete the root folder, and even though it does seems to delete, it will reappear after a restart of the openelec system.

After trying a few methods to get the drive names to be recognised, I gave up. Instead I thought, 'I'll just rescan them to the library, no big deal'. Except, the folders are not scanning correctly. For instance, if press 'c' whilst on my TV folder, and choose 'Change Content' > Set the directory to TVDB (my TV directory contains several correctly named tv show folders) & Run Automated Scan, it skips the majority of the content, and the content it does choose to add, it completely messes up.

For instance, I have the TV show called the I.T Crowd, before the defrag, this tv show folder and all it's contents (as well as every other TV show I have stored), scanned without a hitch. Most if not all contain thumbnails, and .nfo files from sabnzbd, so the majority don't need to do any scraping from the tvmdb. So xbmc scans the I.T Crowd, but decides that it is infact the Tv series Glee Huh If I then go to my Tv Library, The I.T crowd shows up, but all the episodes are renamed as Glee ones.

I realised I've rambled on a fair bit here, so to summarise:-

1) Recently Defraged Harddrive names are not being recognised
2) SSH'ing into my Openlelec system shows the newly defragged drive names as a series of numbers and letters (that I can't rename).
3) SSH'ing into my Openlelec system also shows the old drive folder named XBMC 1TB 5 (the original name of one of the drives, before I defragged them both) that I can't delete.

Sorry for the rambling post. And I realise the problems are likely to be somewhat to do with defragging the drives. But if anyone has a suggestiona as to what I may be able to try to fix the above issues, it would be very much appreciated.

Thanks Smile


Re: External drive name not being recognised + TV shows scanning incorrectly - chewitt - 03-21-2012

The "a5138c2e-1f53-3d7b-a46c-92f2ee47413d" strings look like partition GUID's but they are not GUID's for any filesystem type that I recognise (http://en.wikipedia.org/wiki/GUID_Partition_Table). So i'm wondering if you have GPT partitioned drives and used a GPT unaware defragging tool over them. What tool did you use for the drive defragging? ..and what partition scheme (MBR or GPT) are they using?


Re: External drive name not being recognised + TV shows scanning incorrectly - juice690 - 03-21-2012

Thnanks for the reply chewitt,

Actually surprised anyone read all the way through it! Smile

I'm on a mac, and used 'Drive Genius' I can't find any information, on their website, or reading through the PDF manual that states whether their defragging tool is GPT unaware.

The drive was partitioned using Apples built-in 'Disk utility' http://macs.about.com/od/usingyourmac/qt/partition-types.htm. I believe it it 'GUID' partitioned, pretty sure I wouldn't have used MBR but will check when I get home from work later.

Thanks for your time.


Re: External drive name not being recognised + TV shows scanning incorrectly - juice690 - 03-21-2012

Turns out I did infact partition it as an MBR.


Re: External drive name not being recognised + TV shows scanning incorrectly - juice690 - 03-26-2012

This has me puzzled. I've rescanned the the two drives to get my films back, given up trying to get the names recognised. But the TV episodes are simply not scanning correctly. Every episode of every tv show I have is scanning in as bloody Glee! :laugh:

If I scan the folders the TV show names are all recognised, it's the episodes themselves. i have know Idea how to fix this, or where to start looking. Corrupt database perhaps?

Any help is appreciated.