OpenELEC Forum
How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: STORAGE (https://forum.openelec.tv/forumdisplay.php?fid=60)
+--- Thread: How to get SD cards inserted in my HTPC's cardreader to show up in XBMC (/showthread.php?tid=33119)



How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - martdj - 05-05-2012

Hi all,
I have a HTPC case with a cardreader. If I get friends over to visit and they have a camera with pics, it would be nice if I could just put their SD card/CF card/whatever in my cardreader and show the pics in XBMC. My problem is that XBMC doesn't see any inserted cards. If I ssh into the openelec box (version 1.95.3 x64 ION btw), I also don't see the SD card, so no suprise XBMC doesn't see it. How can I get this to just work the way I want?


Re: How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - chewitt - 05-06-2012

Pastebin 'dmesg' output once you inserted the memory card. If the OS sees the card we can investigate why it is not being mounted. If the OS does not see the card, either something needs tweaking in the BIOS or perhaps the cardreader hardware needs drivers. Something else to try is inserting the card before cold-boot and then seeing if it's visible.


Re: How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - martdj - 05-06-2012

This is the dmesg output. OpenElec is started from a USB stick currently as I'm still testing it whether it can replace my Ubuntu minimal install on the harddrive.

http://pastebin.com/NMHCgLyk

If I mount sde1 to a directory I create in the /storage/media dir I can actually see the content of the SD card, so the problem doesn't seem to be with the driver. The card doesn't automount in XBMC however.


Re: How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - ::sharkbait:: - 11-13-2012

Unfortunatly, I have the same problem.
The cardreader is plugged in via an internal usb port on the motherboard.
When a SD card is inserted the card isn't auto mounted.

Any update on this?


Re: How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - ::sharkbait:: - 11-13-2012

[15871.975077] sd 4:0:0:0: [sdd] 3862528 512-byte logical blocks: (1.97 GB/1.84 GiB)
[15871.976693] sd 4:0:0:0: [sdd] No Caching mode page present
[15871.976696] sd 4:0:0:0: [sdd] Assuming drive cache: write through
[15871.981065] sd 4:0:0:0: [sdd] No Caching mode page present
[15871.981070] sd 4:0:0:0: [sdd] Assuming drive cache: write through
[15871.983824] sdd: sdd1


this is the output of dmesg


Re: How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - ::sharkbait:: - 11-27-2012

BUMP!!!


Re: How to get SD cards inserted in my HTPC's cardreader to show up in XBMC - zimbo_ouen - 02-21-2013

I'm having the same issue and want to watch gopro camera clips straight away.

How frustrating Sad