OpenELEC Forum
No sound over HDMI with Asus P8H77-I and Nightly Builds - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: No sound over HDMI with Asus P8H77-I and Nightly Builds (/showthread.php?tid=52019)

Pages: 1 2


No sound over HDMI with Asus P8H77-I and Nightly Builds - bisk - 10-30-2012

I'm running OpenELEC-Intel.x86_64-devel-20121028141829 on an Asus P8H77-I with an Intel i3 3225 CPU. I've got the PC connected to my TV via the onboard HDMI. For some reason I'm not able to get audio working. When I select HDMI for Audio and Passthrough that setting is not saved and when I go back into the Audio settings, both settings (Audio and Passthrough) are set to blank. In the list of audio devices Custom isn't an option.

I was able to get sound to work by running
aplay -D plughw:0,3 ~/music/Front_Center.wav

Any ideas why can't select Custom in the Audio Settings?


Re: Can't select Custom Audio Output - lrusak - 10-30-2012

No custom audio settings in XBMC frodo


Re: Can't select Custom Audio Output - bisk - 10-30-2012

Well then, that would explain that issue.

Now the main issue though, how can I get audio working?


Re: Can't select Custom Audio Output - bisk - 10-30-2012

For interest's sake, I put OpenELEC-Intel.x86_64-1.0.2 on and set both Audio Outputs to HDMI and everything works perfectly. So now I'm not sure what I need to do to get OE 2 to work on this hardware?


Re: Can't select Custom Audio Output - lrusak - 10-30-2012

How about download an OE 2.0 build? OpenELEC-Intel.x86_64-devel-20121028141829 is not an OE 2.0 build. That build is frodo, not eden


Re: Can't select Custom Audio Output - bisk - 10-30-2012

I put OpenELEC-Intel.x86_64-2.0.0 on and it worked with HDA Intel PCH - hdmi - 0 (ALSA) selected.


Re: Can't select Custom Audio Output - bisk - 10-31-2012

How can I get Frodo working on this PC? I'd like to use Frodo instead of Eden as I'm running the September monthly build of XBMC on my Windows PCs and Apple TV2 and they won't use the same MySQL database, correct?


Re: Can't select Custom Audio Output - bisk - 11-01-2012

Is there anything I can provide to help solve this issue with the Frodo builds?


Re: Can't select Custom Audio Output - lrusak - 11-02-2012

what does the output of
Code:
aplay -l
show with the frodo build?
Perhaps OpenELEC is starting to fast to initialize audio devices before xbmc starts.


Re: Can't select Custom Audio Output - bisk - 11-02-2012

Here's the output from aplay -l
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: VT1708S Analog [VT1708S Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: VT1708S Digital [VT1708S Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: VT1708S HP [VT1708S HP]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0