OpenELEC Forum
3.0 Beta 1 upgrade from 2.0 - dual audio - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: 3.0 Beta 1 upgrade from 2.0 - dual audio (/showthread.php?tid=55362)



3.0 Beta 1 upgrade from 2.0 - dual audio - AikenDrum - 11-28-2012

Sorry if I posted this in the wrong section.

I have a Shuttle XS35GTv2 running ion64 build, I have updated to 2.95.1 from 2.0.0

Before updating to 2.95.1 I had dual audio output working :
1. HDMI to a Samsung TV.
2. Analogue to an old Hifi for music playback without the tv.

I was using the asound.conf for the xs35gt and choosing custom and pcm.both from the system settings.

Since the update I cannot get sound through the analog connection and cannot see how to set it up in the system settings.

Is there a new asound.conf for Frodo that works with my XS35GTv2?
Or can someone point me in the right direction for what should I be doing to get dual audio working ?

I followed the upgrade process described in the wiki.
I deleted my asound.conf, backed up and the deleted my .xbmc directory, backed up and deleted my config directory, installed the update without any problem (although I get a tsc error before it loads the xbmc ui but it is gone before I can make a note of it)

My aplay -l shows this:

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0



Re: 3.0 Beta 1 upgrade from 2.0 - dual audio - lrusak - 11-28-2012

Not possible with Frodo.

If you want dual audio you will have to use Eden.