OpenELEC Forum
Bluetooth audio "connection refused" - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: Bluetooth audio "connection refused" (/showthread.php?tid=56487)



[SOLVED] Bluetooth audio "connection refused" - HamiltonCompany - 12-06-2012

We have used bt-gui to connect a Bluetooth headset. The headset connects properly.

We have also made an asound.conf. When we try to play a movie in XBMC it logs a connection refused error. It does the same thing if we try to connect to btheadset in alsamixer. Does anyone know what would cause this error?

Code:
pcm.btheadset {
type plug
slave {
pcm {
type bluetooth
device 00:02:3C:37:07:BA
profile "auto"
}
}

hint {
show on
description "Twister"
}
}

ctl.btheadset {
type bluetooth
}

Solution is in Post #6


Re: Bluetooth audio "connection refused" - ericab - 12-06-2012

can you provide the make and model of both the bluetooth receiver, and the bt headset ?


**edit

also, what is the output from 'lsusb'


Re: Bluetooth audio "connection refused" - lrusak - 12-07-2012

http://wiki.openelec.tv/index.php?title=Config_sound_over_bluetooth


Re: Bluetooth audio "connection refused" - ancalex - 12-07-2012

Hi HC
Try to remove and pair again your headset, also you can try with another bluetooth dongle.
What OE build are you using?
Regards


Re: Bluetooth audio "connection refused" - HamiltonCompany - 12-07-2012

So this is being used on a Zotac AD10 with built in Bluetooth. I am connecting it to a pair of Creative WP-350 Headphones.

Not only have I tried pairing and repairing and removing, I have formatted the device and started from scratch. I have tried both 2.0 Final and 3 Beta 3.

I had it working in one of the BETA builds of OE about 6 months ago. The wiki entry just does not work as far as I can tell. I used a post (click here) to configure it back then. I am using the same post now and it is giving me the "connection refused" when I try to play it on XBMC or connect to it with alsamixer. It seems like a simple access rights thing.

Here is my lsusb listing:
Code:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 002 Device 002: ID 0bda:0138 Realtek Semiconductor Corp. Card reader
Bus 005 Device 002: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Seems like a set of pretty standard devices and a pretty standard install.

Oh and one more thing. It pairs just fine. I can hear a tone in the headphones when it pairs and I connect it to bt-audio both from the command line and bt-gui.


Re: Bluetooth audio "connection refused" - HamiltonCompany - 12-07-2012

Something changed between OE 2.0 Beta 3 and OE 2.0 Final that caused this.

I was able to fix this by editing the /etc/bluetooth/audio.conf.

I found the fix on this post (click here)

This fix requires unsqashing OE, editing the file and then squashing a new build, producing a new MD5 and updating OE with this custom build.

edit /etc/Bluetooth/audio.conf and under the [General] section add:

Code:
Enable=Source,Sink,Headset,Gateway,Control,Socket,Media

Here is a complete listing of my audio.conf so there is no confusion:
Code:
# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Control,Source
Enable=Source,Sink,Headset,Gateway,Control,Socket,Media

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incomming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0

How do I submit a bug report or change request for this?


Re: Bluetooth audio "connection refused" - ericab - 12-07-2012

Hi Hamilton;

you can submit a bug report here: https://github.com/OpenELEC/OpenELEC.tv/issues/new

(youll need a github account)