OpenELEC Forum
Help with getting PVR setup - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: PVR + LIVE TV (https://forum.openelec.tv/forumdisplay.php?fid=38)
+--- Thread: Help with getting PVR setup (/showthread.php?tid=60893)

Pages: 1 2 3


Help with getting PVR setup - SavellM - 01-12-2013

Hi all.

I wonder if there is a guide getting PVR setup in OpenELEC.
I have tried this once before but it was a nightmare choosing the channels and things, so I gave up.

But now that PVR is included in Frodo im hoping it will fare much better.

I have a Mystique Satix-S2 Sky Xpress Dual tuner, and running OpenELEC 2.99.1 (Frodo RC1).

Is there a good way to get PVR setup, that way I can get rid of Sky and use everything on my HTPC.

Thanks in advance for any help you can provide.


Re: Help with getting PVR setup - Hardcorejax - 01-13-2013

Quickguide;
1, Install tvheadend service from addons , reboot and then go to http://hostname:9981/
2;set up tvheadend https://www.lonelycoder.com/redmine/projects/tvheadend/wiki/Documentation
3,enable and set up tvheadend pvr addon in xbmc
4, enable live tv in xbmc settings

If you want paychannels to work i guess you will need a a cardreader and working oscam server, google for it!


Re: Help with getting PVR setup - SavellM - 01-13-2013

Is there any guide on getting the channels setup?
There are so many it picks up and so many that aren't needed or crap stations.

I would love a setup similar to Sky if possible.
I just want freeview channels or free channels.');


Re: Help with getting PVR setup - PW_suisse - 01-13-2013

Has anyone successfully got PVR to work? I've spend days with different configurations, different releases of openelec with no success. I get always the same errors "PVR not connected" or "No PVR client started". The guides are no help because there is no basis for determining the problem. It's unbelievably frustrating and I would like to know that at least one person has succeeded before I waste anymore time on this. Thanks.


Re: Help with getting PVR setup - Hardcorejax - 01-13-2013

Im running pvr (and have done for several months) works fine !

SavellM map all services to channels and then delete the channels you dont want in tvheadend before enable live tv in xbmc.


Re: Help with getting PVR setup - jenkins - 01-13-2013

it shouldn't map channels you don't have access to...

some crap test channels always get in but as hardorejax says you can delete them...


Re: Help with getting PVR setup - SavellM - 01-16-2013

Ok so today I plugged in my tuner.
Enabled the TVHeadEnd addon that is disabled by default.
Restarted, and tried to access it 192.168.1.4:9981
But nada.. There is no page there.

If I enable TV it says Connection Lost.

What else can I do?


Re: Help with getting PVR setup - Hardcorejax - 01-16-2013

Go to tvheadend service addon config (in xbmc) and enable wait for frontend initialization


Re: Help with getting PVR setup - jenkins - 01-16-2013

do your cards load?

check dmesg and /var/log/messages

is tvheadend running? look at ps output...
you could pastbin the log for us...


Re: Help with getting PVR setup - SavellM - 01-17-2013

Sorry I went to bed.
I will get the logs for you tomorrow night, Im out tonight.

I enabled the addon, and nothing initialized.
Also I did a lsmod, and saw the TV Tuner.