OpenELEC Forum
No audio (HDMI, Openelec 2.0 Fusion) - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: No audio (HDMI, Openelec 2.0 Fusion) (/showthread.php?tid=61430)



No audio (HDMI, Openelec 2.0 Fusion) - bwr827 - 01-17-2013

Setting up a new HTPC build:

· Asus F2A55-M LE Dual DDR3 1866, 7.1 Audio, Gigabit Lan, PCIE, CrossFireX

· AMD A8-5600K APU, Black Edition 3.6GHz w/ 4MB Cache

· AMD MEMORY Entertainment Edition 4GB PC3-12800 CL9 DDR3 SDRAM (1 x 4GB)

Installed Openelec 2.0 (Fusion build) to a 2GB USB drive. Trying to configure audio over HDMI.

· HDMI from HTPC to TV
· Optical pass-through from TV to non-HDMI receiver

Following the audio part of this Perfect Fusion guide, I started trial-and-error using custom settings.

1. Set audio output to HDMI
a. Try Audio output and passthrough device “plughw:0,3”

b. Reset system

Result: “Failed to initialize audio device”

2. Set audio output to Optical
a. Try Audio output and passthrough device “plughw:0,3”

b. Reset system

Result: “Failed to initialize audio device”

3. Set audio output to HDMI
a. Try Audio output and passthrough device “plughw:0,1”
b. Reset system

Result: No error message, but still no audio.

4. Set audio output to Optical
a. Try Audio output and passthrough device “plughw:0,1”
b. Reset system

Result: No error message, but still no audio.

I figured I was onto something with “plughw:0,1” since it got rid of the “Failed to initialize audio device” error message, but I still don’t have audio. I next tried “plughw:0,2” with both HDMI and Optical, and the error message returned.

Any input would be greatly appreciated.


Re: No audio (HDMI, Openelec 2.0 Fusion) - RogerS - 01-17-2013

Why don't you try "OpenELEC 3.0 RC 1"? It is very stable. Setting of audio output is much improved.


Re: No audio (HDMI, Openelec 2.0 Fusion) - bwr827 - 01-17-2013

Didn't realize it was so stable; this is my first time with Openelec, so I went with what appeared to be the safest option.

I'll try 3.0 RC 1, thanks!