OpenELEC Forum
Different TV, No (HDMI) video - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: INSTALLATION (https://forum.openelec.tv/forumdisplay.php?fid=6)
+---- Forum: Update OpenELEC (https://forum.openelec.tv/forumdisplay.php?fid=7)
+---- Thread: Different TV, No (HDMI) video (/showthread.php?tid=62720)



Different TV, No (HDMI) video - fredbmc - 02-26-2013

Applet TV 1. Moved box from Sharp Aquos which works well to Sony Wega. Bootup and access (ssh, smb) is fine, but I end up with black screen. Links below :

cat /var/log/Xorg.0.0.log | paste
DISPLAY=:0 /usr/lib/xbmc/xbmc-xrandr | paste

http://sprunge.us/IRid
http://sprunge.us/gdKM

Thanks for any help!

edit: Sorry. Posted in wrong forum. Don't see where to move.


Different TV, No (HDMI) video - chewitt - 02-26-2013

try running this from the console:

Code:
xrandr --output HDMI-0 --mode 0x1be
if that gives you output? ..lock that change in as the default refresh rate for XBMC


Different TV, No (HDMI) video - fredbmc - 02-26-2013

Thanks for the quick reply!

Nope, that didn't kick it in. Still no output. Bootup does show openelec logo, a couple of flashes, then nada.

Thanks.


Different TV, No (HDMI) video - fredbmc - 02-26-2013

OK! Following your lead and reading over:

http://wiki.openelec.tv/index.php?title=AppleTV_Video_Setup

I discovered the following mode works perfectly!

xrandr --output HDMI-0 --mode 0x1c0

<mode id="0x1c0" name="1280x720" w="1280" h="720" hz="60.00000" current="false" preferred="false"/>

Now, I have to figure out how to lock that change. Thanks!


Different TV, No (HDMI) video - chewitt - 02-27-2013

I'd try 0x1c1 as well. From the output of the set it looks like you're in the US so 59.97Hz is a closer match for the NTSC content you're more likely to have. The settings can be locked by going to SETTINGS > System > Video output > Refresh Rate and selecting the 720p and 60/59.97Hz (or whatever is there).


Different TV, No (HDMI) video - fredbmc - 02-27-2013

Thanks chewitt. Yes, 0x1c1 works well. However, after setting via SETTINGS > System > Video output > and confirming resolution change, it doesn't lock thru reboot. Upon reboot reverts to:

<output name="HDMI-0" connected="true" w="1920" h="1080" x="0" y="0" wmm="0" hmm="0">
<mode id="0x1bd" name="1920x1080" w="1920" h="1080" hz="30.02669" current="true" preferred="true"/>

root ~ # xrandr --output HDMI-0 --mode 0x1c1
fixes it every time. Is there another way to make it stick?

Thanks for your help!