OpenELEC Forum
TVheadend + HDHomeRun on second NIC with static IP - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: PVR + LIVE TV (https://forum.openelec.tv/forumdisplay.php?fid=38)
+--- Thread: TVheadend + HDHomeRun on second NIC with static IP (/showthread.php?tid=62795)

Pages: 1 2 3


TVheadend + HDHomeRun on second NIC with static IP - ultraman - 03-02-2013

To set correct mask just select number 16 in "Netmask Prefixlen" under Network2. This means 255.255.0.0.

"Refresh tuners..." - you are already under "Tuner settings" so I assume if you are refreshing something it must be tuners. But fell free to send me any advice how to make it better. I'm open for suggestions. Maybe Refresh devices... (press me) :cheer:


TVheadend + HDHomeRun on second NIC with static IP - antamone - 03-02-2013

ultraman post=65381 Wrote:To set correct mask just select number 16 in "Netmask Prefixlen" under Network2. This means 255.255.0.0.
Interesting. You inspired me to look up netmasks and address prefix lengths. I guess you can tell I haven't exactly focused on networking protocols in my computing experience, but thanks to you I learned something new today.

I changed the subnet mask for eth1 as you suggested, rebooted, then checked the /var/log/dvbhdhomerun.log. Unfortunately, no change. I then tried increasing the "Pre wait time" in the hdhomerun add-on from 2 seconds to 10 seconds and rebooted. Here is the output from /var/log/dvbhdhomerun.log now:

Code:
################################################################################
# ... output of cat /var/log/dvbhdhomerun.log
# OpenELEC release: Intel.x86_64-2.99.3
#
################################################################################
Num of devices = 1

Device 10187c53 is type 1 and has 2 tuners

Name of device: 10187C53-0
Tuner disabled according to conf file
Auto detecting tuner type
Type of device: hdhomerun_atsc
Auto detecting tuner type set to "hdhomerun_atsc" based on auto detecting
Tuner: 0
Set initial pass-all filter for tuner: 1

Name of device: 10187C53-1
Tuner disabled according to conf file
Auto detecting tuner type
Type of device: hdhomerun_atsc
Auto detecting tuner type set to "hdhomerun_atsc" based on auto detecting
Tuner: 1
Set initial pass-all filter for tuner: 1

As you can see, it is detecting the existing HDHomeRun tuner on my LAN, but not the HDHomeRun Dual tuner connected directly to the OpenELEC system.


ultraman post=65381 Wrote:"Refresh tuners..." - you are already under "Tuner settings" so I assume if you are refreshing something it must be tuners. But fell free to send me any advice how to make it better. I'm open for suggestions. Maybe <em>Refresh devices... (press me)</em> :cheer:
Okay, thanks! I'll probably send a PM your way so we can continue the discussion outside of this thread.


TVheadend + HDHomeRun on second NIC with static IP - ultraman - 03-02-2013

Now I read little more carefully your first post. So your device is directly connected over eth1 to your oe box. Are you sure your settings are correct
Code:
ifconfig -a >/tmp/peter.log
route -n >>/tmp/peter.log
paste /tmp/peter.log
and your hdhomerun has latest firmware? I'm wondering if dvbhdhomerun version does it matter? Today I update it to dvbhdhomerun-0.0.15 but this will come in RC5.


TVheadend + HDHomeRun on second NIC with static IP - antamone - 03-02-2013

Here you go:
Code:
login as: root
##############################################
# OpenELEC - The living room PC for everyone #
# ...... visit http://www.openelec.tv ...... #
##############################################

OpenELEC Version: 2.99.3
root@192.168.2.202's password:
root ~ # ifconfig -a
eth0 Link encap:Ethernet HWaddr 90:2B:34:5C:6D:0E
inet addr:192.168.2.202 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::922b:34ff:fe5c:6d0e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:46019 errors:0 dropped:0 overruns:0 frame:0
TX packets:14131 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4265324 (4.0 MiB) TX bytes:7760348 (7.4 MiB)

eth1 Link encap:Ethernet HWaddr 00:50:B6:0D:DD:A8
inet addr:169.254.1.10 Bcast:169.254.255.255 Mask:255.255.0.0
inet6 addr: fe80::250:b6ff:fe0d:dda8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:141 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:46248 (45.1 KiB) TX bytes:45863 (44.7 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:567 errors:0 dropped:0 overruns:0 frame:0
TX packets:567 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:31583 (30.8 KiB) TX bytes:31583 (30.8 KiB)

root ~ # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.2.3 0.0.0.0 UG 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.2.3 0.0.0.0 255.255.255.255 UH 0 0 0 eth0
root ~ #
I don't know if the tuner has the latest firmware. I should probably just connect it to the LAN and run the latest driver package on one of my Windows machines to update it, and to check if it works in Windows Media Center.

If it is possible to install dvbhdhomerun-0.0.15 in RC3 or RC4 (which I see was just released), would you like me to try that?


TVheadend + HDHomeRun on second NIC with static IP - ultraman - 03-03-2013

dvbhdhomerun is part of the oe system. You must wait for rc5.
Everything else seems fine. Wonder why doesn't work.


TVheadend + HDHomeRun on second NIC with static IP - not-entered - 03-04-2013

I may be missing something here, but how is the HDHomeRun device going to get its IP address if its directly connected?
It should be tryng to get an IP address via dhcp.
I don't think there is a way to configure it to use a static address.


TVheadend + HDHomeRun on second NIC with static IP - ultraman - 03-04-2013

antamone, also try to discover device with hdhomerun_config program. And also try to increase Pre wait time to 25 sec. Read below why. Or maybe Post time.
not-entered, read some hdhomerun doc how it's done:
Quote:Computer IP address configuration:
If the HDHomeRun TECH is connected directly to a computer (no DHCP server) the computer will
need to be configured such that it has a 169.254.x.x IP address (subnet 255.255.0.0). This can be
achieved by statically configuring a 169.254.x.x IP address, or by the computer assigning itself an
AutoIP address.
Windows: Windows will pick an AutoIP address after a period of time if configured to “obtain an IP
address automatically”. This takes 3 minutes on XP and 30 seconds on Vista. Setting a static
169.254.x.x IP address will avoid this delay.
The HDHomeRun will take 20 seconds from link-up until it can be addressed using an AutoIP
address.



TVheadend + HDHomeRun on second NIC with static IP - antamone - 03-06-2013

I connected the HDHomeRun Dual tuner to my LAN and installed the latest HDHomeRun driver package on a Windows PC, which then updated the firmware on the tuner to the latest release. I then verified the tuner was working by watching some channels in Windows Media Player.

I then reconnected the HDHomeRun Dual directly to the OpenOLEC system. I increased Pre wait time to 25 seconds, restarted, and then did a Refresh in dvbhdhomerun. The tuner then appeared!

Also, here is the output from hdhomerun_config:
Code:
login as: root
##############################################
# OpenELEC - The living room PC for everyone #
# ...... visit http://www.openelec.tv ...... #
##############################################

OpenELEC Version: 2.99.3
root@192.168.2.202's password:
root ~ # hdhomerun_config discover
hdhomerun device 10187C53 found at 192.168.2.180
hdhomerun device 10383AC3 found at 169.254.81.85
root ~ #
The second device is the one connected directly to the OpenELEC system. So, we've definately made progress!

Unfortunately, the Tvheadend server/backend still doesn't see the tuner. I tried disabling and renabling the TVheadend frontend, and uninstalling and reinstalling the Tvheadend server/backend, with no success.


TVheadend + HDHomeRun on second NIC with static IP - ultraman - 03-06-2013

Check the file /var/log/dvbhdhomerun.log too. Also check if you have anything under /dev/dvb/.


TVheadend + HDHomeRun on second NIC with static IP - antamone - 03-06-2013

Here you go:
Code:
################################################################################
# ... output of cat /var/log/dvbhdhomerun.log
# OpenELEC release: Intel.x86_64-2.99.3
#
################################################################################
Num of devices = 2

Device 10187c53 is type 1 and has 2 tuners

Name of device: 10187C53-0
Tuner disabled according to conf file
Auto detecting tuner type
Type of device: hdhomerun_atsc
Auto detecting tuner type set to "hdhomerun_atsc" based on auto detecting
Tuner: 0
Set initial pass-all filter for tuner: 1

Name of device: 10187C53-1
Tuner disabled according to conf file
Auto detecting tuner type
Type of device: hdhomerun_atsc
Auto detecting tuner type set to "hdhomerun_atsc" based on auto detecting
Tuner: 1
Set initial pass-all filter for tuner: 1

Device 10383ac3 is type 1 and has 2 tuners

Name of device: 10383AC3-0
Tuner type set to "ATSC" based on conf file
Using full name
Tuner: 0
Set initial pass-all filter for tuner: 1

Name of device: 10383AC3-1
Tuner type set to "ATSC" based on conf file
Using full name
Tuner: 1
Set initial pass-all filter for tuner: 1

Registered tuner, id from kernel: 0 name: 10383AC3-0
Registered tuner, id from kernel: 1 name: 10383AC3-1

/dev/dvb/:
Code:
root ~ # find /dev/dvb/
/dev/dvb/
/dev/dvb/adapter1
/dev/dvb/adapter1/frontend0
/dev/dvb/adapter1/dvr0
/dev/dvb/adapter1/demux0
/dev/dvb/adapter0
/dev/dvb/adapter0/frontend0
/dev/dvb/adapter0/dvr0
/dev/dvb/adapter0/demux0