OpenELEC Forum
watchdog and umlauts broken? (+ shutdown Prob) - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: MISCELLANEOUS (https://forum.openelec.tv/forumdisplay.php?fid=23)
+--- Thread: watchdog and umlauts broken? (+ shutdown Prob) (/showthread.php?tid=63060)



watchdog and umlauts broken? (+ shutdown Prob) - canuma - 03-14-2013

Just recently tried openelec and it is amazing, just what i was looking for. However i now have a huge problem with the xbmc addon, watchdog.
My System:
Generic PC, Core2duo @ 3Ghz
2 Harddrives @ 1 TB each
4 GB Ram.
OS: openelec 2.99.4 updated to 2.99.5

The Problem: I liked the Idea to have my Library updated automagically. So I enabled watchdog.
However, when I started to add content which have umlauts, watchdog gave an error, stating library xy not watching (xy is a lib path)
So right now watchdog basicly isn't working. Not that much of a problem, however, as long as watchdog is active and it can't work correctly, the system hangs at shutdown. Was able to reproduce it, did even a fresh install, whenever watchdog was active (and broken) it prevented the system from shutting down. XBMC seems to hang, however I am able to ssh to the box and shut it down manually.

Here is a snipplet of the XBMC log:

11:53:45 T:2850028352 ERROR: Traceback (most recent call last):
11:53:45 T:2850028352 ERROR: File "/storage/.xbmc/addons/service.watchdog/core/main.py", line 199, in watch
11:53:45 T:2850028352 ERROR: observer.schedule(event_handler, path=path, recursive=RECURSIVE)
11:53:45 T:2850028352 ERROR: File "/storage/.xbmc/addons/service.watchdog/lib/watchdog/observers/api.py", line 340, in schedule
11:53:45 T:2850028352 ERROR: timeout=self.timeout)
11:53:45 T:2850028352 ERROR: File "/storage/.xbmc/addons/service.watchdog/lib/watchdog/observers/inotify.py", line 752, in __init__
11:53:45 T:2850028352 ERROR: self._inotify = Inotify(watch.path, watch.is_recursive)
11:53:45 T:2850028352 ERROR: File "/storage/.xbmc/addons/service.watchdog/lib/watchdog/observers/inotify.py", line 453, in __init__
11:53:45 T:2850028352 ERROR: self._add_dir_watch(path, recursive, event_mask)
11:53:45 T:2850028352 ERROR: File "/storage/.xbmc/addons/service.watchdog/lib/watchdog/observers/inotify.py", line 636, in _add_dir_watch
11:53:45 T:2850028352 ERROR: for root, dirnames, _ in os.walk(path):
11:53:45 T:2850028352 ERROR: File "./Lib/os.py", line 284, in walk
11:53:45 T:2850028352 ERROR: File "./Lib/posixpath.py", line 71, in join
11:53:45 T:2850028352 ERROR: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 30: ordinal not in range(128)

Last line makes me wonder, shouldn't it be utf-8 anyway? I had a short look into watchdog and it seems it actually does decode utf-8 there, so I assume that it has something to do with python. Why it hangs xbmc, i have no Idea.

So should I fill a bug report, or did I miss some settings related thing?


watchdog and umlauts broken? (+ shutdown Prob) - codefreeze - 03-14-2013

I have exactly the same problem since the upgrade to 2.99.5


watchdog and umlauts broken? (+ shutdown Prob) - poena - 03-14-2013

When you disabled watchdog, could you shutdown the machine?


watchdog and umlauts broken? (+ shutdown Prob) - e_esprit - 03-14-2013

codefreeze post=66804 Wrote:I have exactly the same problem since the upgrade to 2.99.5
In fact the problem didn't came with OpenELEC 2.99.5 (got it first on 2.99.4 before I upgraded), but with Library Watchdog 0.7.3.
But it seems to happen only with OpenELEC (or at least, only OpenELEC users reported it, or everybody is using OpenELEC now :laugh: ) :
http://forum.xbmc.org/showthread.php?tid=128896&pid=1366085#pid1366085


watchdog and umlauts broken? (+ shutdown Prob) - e_esprit - 03-14-2013

poena post=66856 Wrote:When you disabled watchdog, could you shutdown the machine?
Yep !


watchdog and umlauts broken? (+ shutdown Prob) - shedrock - 03-15-2013

I am having the same issue. Sad


watchdog and umlauts broken? (+ shutdown Prob) - drexel75 - 07-31-2013

ok first off I have always had a shutdown issue with openelec. I think that its cuz the majority of the time i have had watchdogs enabled even tho it wasnt working for me lol. Ive gotten so used to rebooting thru ssh that i rarely check to see if it works from my openelec machine. Now i did notice that i was able to reboot from OE the short time i had watchdogs disabled. But it took like 5 to 10 minutes for it to reboot. for me ssh is instant. So watchdog is probably the issue here. I dont shut my machine down much so its not a big deal to me.

Ok for the main issue of Watchdogs not working. Until today it has never worked for me ever. not the least bit. I always got the same messages: failed to watch ___ harddrive. I did a couple of minor tweaks today and it works like a charm. It works better than the other library updaters if you ask me because i have such a huge music collection that xbmc gives up on scanning anything new to my library. Well now it works.

Here are the changes i made:

Configure addon, Advanced:
Method: Polling
Delay: 5

I hope this helps. Sorry if im long winded here i just wanna make sure i get across any useful info.