OpenELEC Forum
OpenELEC doesn't recognize my second HDD - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: STORAGE (https://forum.openelec.tv/forumdisplay.php?fid=60)
+--- Thread: OpenELEC doesn't recognize my second HDD (/showthread.php?tid=63196)



OpenELEC doesn't recognize my second HDD - loonling - 03-21-2013

It seems like this should be easy enough. I've scoured the forum looking for an answer and I just can't find a remedy. Admittedly, I'm still a novice when it comes to Linux stuff.

My second HDD is a previously formatted 500gb NTFS SATA drive. OpenELEC can't seem to find it. I am not really sure how to resolve this. Any ideas?

openelec:~ # cat /proc/partitions
major minor #blocks name

7 0 113508 loop0
8 0 58615704 sda
8 1 183296 sda1
8 2 58415104 sda2
8 16 488386584 sdb
8 17 488384001 sdb1
11 0 1048575 sr0


openelec:~ # mount
rootfs on / type rootfs (rw)
none on /dev type devtmpfs (rw,relatime,size=3829392k,nr_inodes=957348,mode=755)
none on /proc type proc (rw,relatime)
none on /sys type sysfs (rw,relatime)
/dev/sda1 on /flash type ext4 (ro,noatime,data=ordered)
/dev/sda2 on /storage type ext4 (rw,noatime,data=ordered)
/dev/loop0 on / type squashfs (ro,relatime)
none on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
none on /dev/shm type tmpfs (rw,relatime)
none on /var type ramfs (rw,relatime)
none on /sys/kernel/debug type debugfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

openelec:~ # parted -l
Model: ATA CSSD-V60GB2 (scsi)
Disk /dev/sda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 189MB 188MB ext4 primary boot, legacy_boot
2 189MB 60.0GB 59.8GB ext4 primary


Model: ATA WDC WD5000AAKS-0 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.3kB 500GB 500GB primary ntfs


OpenELEC doesn't recognize my second HDD - loonling - 03-23-2013

I think I need to manually mount my second HDD, but I'm having trouble getting the syntax right.

This is what I'm trying, with the error I'm getting:

openelec:~ # mount /dev/sdb1 /storage/mediafiles/
mount: mounting /dev/sdb1 on /storage/mediafiles/ failed: Invalid argument


OpenELEC doesn't recognize my second HDD - chewitt - 03-23-2013

Create the directory you're mounting to first, and tell it the filesystem type with -t <blah>, e.g.

Code:
mkdir -p /storage/mediafiles
mount -t ntfs /dev/sdb1 /storage/mediafiles



OpenELEC doesn't recognize my second HDD - loonling - 03-23-2013

Awesome. Thanks.

One problem:

openelec:/ # mkdir -p /storage/mediafiles
openelec:/ # mount -t ntfs /dev/sdb1 /storage/mediafiles
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
mount: mounting /dev/sdb1 on /storage/mediafiles failed: No such device


OpenELEC doesn't recognize my second HDD - loonling - 03-23-2013

I plugged my Windows drive back into the system and am running chkdsk on the second drive. It's taking forever, so I guess there really were some issues with the file system. Hopefully, once this is complete, I can plug the OE drive back in and all will be well. If not, I'm sure I'll be posting more questions.


OpenELEC doesn't recognize my second HDD - loonling - 03-24-2013

Running chkdsk in Windows didn't solve the problem. I've given up and am in the process of copying all of the files off so I can format it to EXT3 or 4 and then copy the files back over. Sigh.


Re: OpenELEC doesn't recognize my second HDD - bustamelon - 03-24-2013

I think that's your best bet. NTFS support in Linux has never been 100% reliable. If you need to access the drive from a windows machine, you can always make it a samba share.