OpenELEC Forum
dts-hd-ma over hdmi - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: dts-hd-ma over hdmi (/showthread.php?tid=64521)

Pages: 1 2


dts-hd-ma over hdmi - stasik - 05-24-2013

in my audio settings i had "output" as "hdmi" and everything was working fine with dts, but when i tried to watch dts-hd master, i heard nothing. my player is connected to a/v receiver via hdmi cable and can decode most audio codecs, and another hdmi cable from receiver to tv. my receiver was not getting any sound as display was not displaying any info. i by accident changed the output setting to "optical/coaxial" and i had sound, and the receiver displayed dts-hd-mix. so why its not working with the "hdmi" option? i have no other cables connected, just 2 hdmi cables? hope this workaround will help others with the same issue
system: ion 64 bit 3.0.3


dts-hd-ma over hdmi - chewitt - 05-25-2013

I suspect "can decode most audio codecs" does not include DTS-HD - what make/model of AVR do you have?


dts-hd-ma over hdmi - stasik - 05-25-2013

if it can not decode, why it works when i change the setting to "coaxial"? the model is Sony STR-DN1030


dts-hd-ma over hdmi - vicbitter - 05-26-2013

You need to turn on debugging and post your xbmc.log for folks to be able to help...


dts-hd-ma over hdmi - stasik - 05-26-2013

this is a sample of my file... can any one try and see if they can play it?
http://ul.to/p60m7n66


dts-hd-ma over hdmi - MdMa - 06-10-2013

If you have an ION (not ION2) it cannot bitstream any HD Audio codecs (DTS-MA, TrueHD).

You would be getting sound out of coax because coax cannot bitstream HD Audio and thus would only bitsteam the DTS Core (1.5Mbit).

You should deselect TrueHD and DTS-MA capable receiver, this way, when you have a DTS-MA or TrueHD track, it will be decoded by the ION and passed to your AVR as LPCM.

This is all providing you do in fact have an ION GPU.

[Image: gRGvs.jpg]


dts-hd-ma over hdmi - Alexandro - 06-10-2013

Dear MDMA,
Could you please elaborate further why in case ion is not capable of decoding hd audio streams and pass it to the receiver as a multichannel bitstream, in the same time windows based xbmc (the same ion board) is doing so and my onkyo 875 reports dts-hd ma, Dolby true-hd respectively?

Some of the devs from the xbmc main forum mentioned that the issue is connected somehow with the new ae and the recently abondoned pulse audio drivers.

Thank you.


dts-hd-ma over hdmi - fritsch - 06-10-2013

Besides that you posted a windows screenshot :-) We have no WASAPI on Linux.


dts-hd-ma over hdmi - MdMa - 06-11-2013

Alexandro post=75979 Wrote:Dear MDMA,
Could you please elaborate further why in case ion is not capable of decoding hd audio streams and pass it to the receiver as a multichannel bitstream, in the same time windows based xbmc (the same ion board) is doing so and my onkyo 875 reports dts-hd ma, Dolby true-hd respectively?

Some of the devs from the xbmc main forum mentioned that the issue is connected somehow with the new ae and the recently abondoned pulse audio drivers.

Thank you.

The ION IS capable of decoding DTS-MA/TrueHD and passing it to your AVR as LPCM, but it is not capable of bitstreaming (passing it un-decoded) to your AVR. You will not get DTS-MA/TrueHD to light up on your AVR with the ION (1) GPU.

If you have an ION2 then bitstreaming of HD Audio is possible, but unsure if it is working at the moment.. I only have an ION to test with sorry.

The question is are you using an ION or ION2?


fritsch post=75986 Wrote:Besides that you posted a windows screenshot :-) We have no WASAPI on Linux.

The screen shot was something I found in Google Images and was only to show what the audio settings/toggles look like.


dts-hd-ma over hdmi - Alexandro - 06-11-2013

Thank you for your reply,
I am sorry for the misleading information I provided in my last post.
I have two HTPCs. The first one (I am experiencing problems with) is an AT3IONt based which is a ION-1 motherboard. When i had DTS-HD MA displayed on my Onkyo SR875, the tests was performed with the other one which is based on AT5IONt which is ION-2.
So what the workaround is? Does Nvidia 610 video card installation in the ION1 based system will allow me to have a HD Audio support?
Thank you in advance again.
BR.