OpenELEC Forum
[FUSION_X64] Internet Video Streams Problems 3.X.X - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: MISCELLANEOUS (https://forum.openelec.tv/forumdisplay.php?fid=23)
+--- Thread: [FUSION_X64] Internet Video Streams Problems 3.X.X (/showthread.php?tid=66394)



[FUSION_X64] Internet Video Streams Problems 3.X.X - SonicNKT - 08-17-2013

Hi,
im having a Problem with some Internet Video Streams.
For Example following Addons (Tagesschau.de netzkino.de, available in officia xbmcl Repo).

Starting a Stream from one of those addons causes xbmc to freeze in the menu, Audio Plays fine in the background. The System is fully responsive through SSH acces.
After about 1/4 of the internet Stream, xbmc returns to normal. The Video of the Streams starts playing and the System comes fully responsive again.

Other streaming addons like blip.tv for exampel work fine and local Videos as well as my library (connected through NFS) wont show this Problem as well.

The problem seems to happen for every 3.X Build i tried (3.0.1, 3.0.6, 3.1.5).

Hope someome has any idea how to fix this. Its really annyoing with longer streams...
Thanks in Advance!

PS: i tried those addons on xbmc (windows/mac) and they play fine, so because of that i think its an oe related problem.


[FUSION_X64] Internet Video Streams Problems 3.X.X - SonicNKT - 09-13-2013

sorry to bump this up...
but i still havent found a solution, updating to 3.1.7 aswell didnt fix it.
I also tried to google the problem but couldnt find anything like it.
If you need more information please tell me!

It seems to be exactly this issue:
https://github.com/OpenELEC/OpenELEC.tv/issues/2236

i created a log attached to this thread:
[attachment=1373]streaming_problems.zip[/attachment]

it covers starting the plugin and starting the stream at arround 20:57:02, the freeze of xbmc occurs at arround 20:57:03-09 (but audio plays fine)
And xbmc unfreezing and playing video at 20:57:31.
The videostream is arround 2 min long, the freeze is about 20-25 seconds long. With a longer video stream the time xbmc will increase as well. about 1/4 of the lenght of the video

UPDATE:
This is the link of the video i try to open in the attached log:
http://media.tagesschau.de/video/2013/0913/TV-20130913-2007-3601.webl.h264.mp4

Download this file and playing it from my openelec harddrive works fine without any problems!


[FUSION_X64] Internet Video Streams Problems 3.X.X - SonicNKT - 01-21-2014

Just updated to the latest Version 3.2.4...
And this bug is still present, atleast in the fusion builds...

Can somebody please help me? im getting really frustrated... everything works fine but this is really annoying..


[FUSION_X64] Internet Video Streams Problems 3.X.X - klojum - 01-21-2014

Ever tried a Gotham nightly build?
Run it from USB, if you want to test.
http://snapshots.openelec.tv/


[FUSION_X64] Internet Video Streams Problems 3.X.X - SonicNKT - 01-21-2014

There is no fusion build so i just tried the latest generic x64 one:
OpenELEC-Generic.x86_64-devel-20140118160802-r17039-g3f6da49.tar

after installing this on a empty usb drive i only get following message on the boot screen:

***Error in prepare_sysroot: final_check: Could not find system. ****
### Starting debuggingshell .... and so on

i tried different USB Drives and also a older i386 build:
OpenELEC-Generic.i386-devel-20140116221038-r17010-g4dd0018.tar
but with the same result...


[FUSION_X64] Internet Video Streams Problems 3.X.X - klojum - 01-21-2014

Hmm... Well, first of all: there will be no more specific builds for Fusion, ION and Intel for Gotham.
Those will all be bundled in the Generic build, which you already found.

Why the Gotham build fails, I personally have no idea. Perhaps one of the devs can have a look into it.


RE: [FUSION_X64] Internet Video Streams Problems 3.X.X - vydernugadaa2 - 10-04-2020

наро138шрифCHAPXVIISamaстудThomPalaPoiniMPAFiskBarbOrieАлешsingWaynPJ85FortSentДумбThomВеде
AlphГозеRaymGeorPenhHomeGypsсоавШишксертСодезнатСтепSupePlaiКасаАрлаFyodврагРадиДугиJaneSala
LoveCaroAndyYvesсторКацускоммолиочерWernФереImagСадоEnerГромKeigНикиRobeпатрНекрХилпPierJohn
сертTombТрубздесИллюDeadMickPlugТопиWindKissClanGardArtsИллюRighссылстрапоняDreaDaniLancXIII
diam(184FuxiSwarMiyoGeorпришNicoXVIIAndrBillTranSacrGuilAllaPrelбиблRobbSwarSanoHaveKingChar
Last(ВДНИзобPion(196CandBoscRolsКитаAlfoлитьАртиАртиFredPola9039BradсереARAGSusaхорорастFLAC
ALL4инстинстМищеTracкольWindCoreDaewPhilRulesupeKenwсклаWhisMMORЛитРМухаPhilEmilФомиБараЛитР
ВолоЛитРдопоXVIIОсееКрылБухаКоптКержDatadessкиноHighОбущDolbустрРоссRock(РасSongKennGeryDown
IntoКолеDaviМухаMamaПлакSafeДайнНовиТыся0732СуетHiroПопоПимеChriНенаГогуWaltНекрРоньPionPion
PionMicrCounиздаПоляЛевивозрстихЯковСороCambавтоФормtuchkasPockLawr