OpenELEC Forum
3.2.4, CIFS booting doesn't work? - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: NETWORK (https://forum.openelec.tv/forumdisplay.php?fid=49)
+---- Forum: PXE / Network boot (https://forum.openelec.tv/forumdisplay.php?fid=50)
+---- Thread: 3.2.4, CIFS booting doesn't work? (/showthread.php?tid=68391)



3.2.4, CIFS booting doesn't work? - Rickenbacker - 12-02-2013

I've been PXE booting openelec 2.0 for quite some time with no problems. I even played a bit with 2.99.5 betas and that booted fine too.
I've now tried booting 3.2.4, and it doesn't work.
The following is my pxelinux.cfg/xxx file:
Code:
KERNEL openelec/3.2.4/KERNEL
APPEND ip=dhcp boot=CIFS=//172.16.1.1/PXE,user=xbmc12,password=x,prefixpath=openelec/3.2.4/ disk=CIFS=//172.16.1.1/xbmc12,user=xbmc12,password=x,prefixpath=storage/ debugging
This is the output I see on the screen with the openelec logo:
Code:
cp: can't stat '/flash/SYSTEM' : No such file or directory
Mount: mounting /dev/SYSTEM on /sysroot failed: no such file or directory
Mount: mounting /dev/SYSTEM on /sysroot failed: no such file or directory
...
*** Error in prepare_sysroot: mount_common: Could not mount /dev/SYSTEM
Issuing the "mount" command I can see that both /flash and /storage are mounted.

Any suggestions as to what I may be able to do to make CIFS booting work with 3.2.4?


3.2.4, CIFS booting doesn't work? - bassebus - 03-02-2014

Cant get it to work either!
I see the logo and the fc-cache error, http://openelec.tv/forum/64-installation/68511-sbin-init-etc-init-d-35-fontconfig-line-34-fc, it then hangs.
Same with all 3.x.x builds Sad

It does create a folder structure in the .../storage folder, and 2.x images will boot so it's not a problem with my pxe-environment...

Any ideas?