OpenELEC Forum
OpenVpn usage - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: INSTALLATION (https://forum.openelec.tv/forumdisplay.php?fid=6)
+---- Forum: Update OpenELEC (https://forum.openelec.tv/forumdisplay.php?fid=7)
+---- Thread: OpenVpn usage (/showthread.php?tid=68661)



OpenVpn usage - t_valhalla - 12-24-2013

Hi all

i tried to configurate a vpn using the graphical interface, and it even manages to connect
however there is no real comunication because it forces the use of device TUN, and my server requires TAP

runing in a ssh session a command like
openvpn /storage/downloads/myvpn.ovpn
works very well, and respects the
dev tap
line in tne config file

its the configuration that is created by the web interface that insists on using TUN device

i tried several combinations of lines in the config files created, like: (check the last line)
__________________________________________________________________
[global]
Name = vpn1

[provider_openvpn]
Type = openvpn
Name = vpn1
Host = http://www.myopenvpnserver.com
OpenVPN.Key = /storage/downloads/xxx.pem
OpenVPN.Cert = /storage/downloads/xxx_yyy.pem
OpenVPN.CACert = /storage/downloads//www_cacert.pem
Domain = vpn
advanced = 1
OpenVPN.CompLZO = 1
OpenVPN.Port = 91194
OpenVPN.dev = tap
_________________________________________________________
OpenVPN.dev = tap
OpenVPN.dev-type = tap
OpenVPN.device = tap



i tried several options, but the vpm keeps using device TUN


anyone has an idea of how to tell the sustem to use TAP and not TUN device ??

many thanks


OpenVpn usage - e n - 12-24-2013

http://openelec.tv/forum/69-network/66714-openvpn-solution-butchered-together-solution-open?start=45#92926