OpenELEC Forum
Manual installation on microSD card - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: SPECIAL SYSTEMS (https://forum.openelec.tv/forumdisplay.php?fid=10)
+---- Forum: Solidrun CuBox-I (https://forum.openelec.tv/forumdisplay.php?fid=17)
+----- Forum: Installation (https://forum.openelec.tv/forumdisplay.php?fid=18)
+----- Thread: Manual installation on microSD card (/showthread.php?tid=69082)



Manual installation on microSD card - davorin - 01-23-2014

A simple instruction on how to write SYSTEM/KERNEL and boot.scr to the microSD card?

Which u-boot image did you choose?

Few CuBox-I1 are waiting to test here and I'm curious in comparison to geexbox, which uses around 60% CPU load on a Bluray RIP with DTS 5.1 HD audio decoding.


Manual installation on microSD card - guppy - 01-23-2014

+1

As I recall there was a script to create a usb/sd card when I installed openelec on all my assorted other boxes - it seems to be missing from
OpenELEC-Cuboxi.arm-devel-20140123155012-r17126-gceb58b6

I half way tempted to just partition the sd card and just dump the SYSTEM, KERNEL and boot.scr on the first partition but I've a sneaky feeling the loader has to sit in a specific place


Manual installation on microSD card - davorin - 01-23-2014

Instruction was posted here at cubox forum:

http://imx.solid-run.com/forums/viewtopic.php?f=7&t=457#p2490

You need to replace the u-boot image with your model's one version as there is no SPL for this...


Manual installation on microSD card - davorin - 01-23-2014

Nice...posting error log is reported as SPAM here (o;


Manual installation on microSD card - nikotime - 01-23-2014

Plonk it in pastebin!


Manual installation on microSD card - sraue - 01-23-2014

also posted here:
http://openelec.tv/forum/143-installation/69085-cubox-i-manual-installation

use this thread for talk about the installtion (the other is locked and sticky


Manual installation on microSD card - guppy - 01-23-2014

Installation went painlessly - even wireless mode worked in first go Smile

few issues
  • Time zone seems to be wrong (-1 hour)
  • There is sligth flicker when opening and closing menus
  • the box isn't picking up the shared DB from advancedsettings.xml

The last point may be a version issue I'll have to look into it tomorrow


Manual installation on microSD card - guppy - 01-24-2014

- Timezone isn't being picked up automatically ( both my other openelec boxes did this )
- CEC control never recovers from a lost session and it's impossible to re-establish it manually without rebooting ( session sometimes gets lost during boot - which is very annoying ) [SONY]
- CEC glitches before XMBC launch and never recovers [SAMSUNG]
- TV signal - MPEG2 (sd content) and MPEG4 (hd content) has visible artifacts and lag ( wireless, will try wired later )
- channel menu has visible artifacts (black shimmering holes in the "selected item" graphics )
- When changing menus animated menus seem to flicker in and out of existence rapidly during their animation ( I'll try and capture this on video, it's hard to explain )
- bluetooth isn't being detected
- reboot just locks the system and feezes



There are more bugs but I want to rule out SD card corruption for those first

I noticed that why my other 3.0.0 openelec boxes are running XBMC 12.2 this is XBMC 13 - which is properly why the shared DB is missing, is this intentional and if so when will regular XBMC get this version ( so my shared DB can actually be shared )


Manual installation on microSD card - guppy - 01-24-2014

Edited the post above - is it ok to batch post bugs like this or do you want separate posts / bug tracking on them?


Manual installation on microSD card - fredentoft - 01-28-2014

Regarding xbmc version the answer is quite simple: The support for cubox-i is being worked on for the upcoming Gotham version (13.x), and my guess is that there is very little interest in backporting the support to Frodo (12.x). This however should not be the reason shared database is not working since the schema for both Frodo and Gotham are the same. Even if there were a schema-difference Gotham would upgrade (or copy) the database to the new schema and use that (i.e. you would have two out-of-sync databases or in the case of upgrade no databaseaccess from Frodo). Geexbox also uses (for obvious reasons) Gotham, and the ones I've tried there has had no noticable problem with shared MySQL.