OpenELEC Forum
720p vs 1080p playback - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: SPECIAL SYSTEMS (https://forum.openelec.tv/forumdisplay.php?fid=10)
+---- Forum: Solidrun CuBox-I (https://forum.openelec.tv/forumdisplay.php?fid=17)
+----- Forum: Usage (https://forum.openelec.tv/forumdisplay.php?fid=19)
+----- Thread: 720p vs 1080p playback (/showthread.php?tid=69432)



720p vs 1080p playback [SOLVED w/ latest nightly] - mastrmind - 02-12-2014

Installed 0209 snapshot a couple of days ago on an i4pro. I am unable to play 720p mkv files, while the 1080p counterpart is playing correctly. When I try playing a 720p mkv *movie*, I get a black window with the correct sound as if I were playing a trailer. When I try to play a 720p *tv* rip, I get only the sound while the XBMC TV library menu stays present on the screen. If I switch to any 1080p, whether TV or Movie, it plays as expected. This is reproducible in both Confluence and AEON Nox, and both instances of 720p play can be exited w/ the stop button on both my remote and Yatse.

Tailing the xbmc.log file (tail -f xbmc.log | grep ERROR), I see a continuous flow of "ERROR: Decode - VPU decode failed with error code 7" while the file is playing, while these errors are not present during 1080p playback.

Let me know if you need further info.

THanks


720p vs 1080p playback - klojum - 02-13-2014

One of the things we haven't been able to implement yet, is have OpenELEC send us full xbmc logs via brainwaves. Anyway, a single desciption as "ERROR: Decode - VPU decode failed with error code 7" won't cut it. Errors can originate and start from any moment on, that is why a complete xbmc.log is always good place to start. Upload it via the built-in pastebinit support or upload it somewhere manually, and post the URL(s) here.


720p vs 1080p playback - mastrmind - 02-13-2014

Sorry, I should have known better. I recreated the scenario just now so the log file is fresh.

https://www.dropbox.com/s/k8ru5vq6q3zem3s/xbmc.log


720p vs 1080p playback - mastrmind - 02-13-2014

On a side, and potentially related subject, I am unable to change the resolution within openelec. It's at 1920x1080p/60hz, which is fine, but I wanted to see whether it was the resolution setting that might be contributing to this. The monitor setting is set to ?0?, and I can change it to ?-1", but it flips back as soon as I deselect it. I also tried a different skin, and the behavior is the same except when playing a 720p movie in which case it behaves like playing a 720p movie... (menu stays in the forefront, audio plays, no picture), wheres in Nox, I get a "trailer" window that pops up w/ no video.

Let me know how I can be of further assistance.

Thanks


720p vs 1080p playback - mastrmind - 02-14-2014

FYI, this question got a bit more traction on the cubox xbmc forums. I updated to the latest nightly and it resolved the 720p issue. THanks