OpenELEC Forum
Wrong channels 5.1 - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: Wrong channels 5.1 (/showthread.php?tid=70603)



Wrong channels 5.1 - kreap - 04-29-2014

Hi,

I have a AsRock 330HT and since I update to 3.95.x (generic) the sound channels of my 5.1 system are wrong mapped...
Any ideas to resolve this problem???

Thanks,
Tiago


Wrong channels 5.1 - LastMile - 04-30-2014

http://wiki.openelec.tv/index.php?title=Config_sound_asrock_ion330


Wrong channels 5.1 - kreap - 04-30-2014

The problem is that the versions os the last betas is based no "Gotham"... So the audio menus doesn't have those options!

Thanks


Wrong channels 5.1 - LastMile - 04-30-2014

Pretty sure you can still remap the channels

Add a asound.conf with the following content in the /storage/.config directory or in the configfils samba share:
Code:
pcm.!default {
type plug
slave {
pcm both
}
}

pcm.both {
type route
slave {
pcm hdmi
}
ttable.0.0 1
ttable.1.1 1
ttable.2.4 1
ttable.3.5 1
ttable.4.2 1
ttable.5.3 1
ttable.6.6 1
ttable.7.7 1
}

Give it a try, but I can't guarantee it'll work. I switched to Gotham nightlies when I picked up an Intel NUC late last year, so haven't had to deal with sound config on the Ion since.


Wrong channels 5.1 - kreap - 05-01-2014

Thanks LAstMile but didn't worked...


Wrong channels 5.1 - Raegedoc - 05-08-2014

Hi,

I also have a ION 330HT and just upgraded to OpenElec 4.0. I can confirm I have wrong channels in 5.1.
It worked fine with the previous version 3.2.4.

Anything can be done for 4.0 ?

Thank you


Wrong channels 5.1 - Raegedoc - 05-08-2014

Update to my previous post

I was able to turnaround my problem for now by following this hint : http://openelec.tv/forum/124-raspberry-pi/70743-openelec-4-0-hdmi-5-1-audio-not-working

Seems like a problem on 4.0 when compared to 3.2.4


Wrong channels 5.1 - bob0 - 05-09-2014

I'm having the exact same problem on the exact same platform. Can you explain exactly what you did to fix this? I'm still having the problem.


Wrong channels 5.1 - Raegedoc - 05-09-2014

Feejus said : "Change your skin to default skin (the option might not appear on other skins as they have not updated them yet). Once done go to System on the left hand side you can see it says "Standard" change the Standard to Advanced and now go to your System Audio setting you should have loads of option including "Pass through" and DTS etc. enable them all and you will hear some great surround sound again"