OpenELEC Forum
No sound through HDMI output - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: No sound through HDMI output (/showthread.php?tid=71962)



No sound through HDMI output - dpounch - 07-10-2014

Hi all,

I hope this is the right place for this topic.

I have a NUC I3 Haswell on which I installed Openelec (of course) and I recently bought a home cinema amplifier PIONEER VSX-828 K. I connected the NUC on the amp and I tested some movies first. No problem. Sound is great.
I tried to listen to music and surprise, there is no sound coming out of the amp ... ! I checked the settings for the audio output and everything seems ok to me (everything is linked to the HDMI output and each type of audio output is checked)

So question is: am I missing something? Why movies audio is ok and not music?
Detail: the default sound of XBMC also is not playing when I switch from a category to another.
The NUC is linked on the HDMI input "DVD". Does it have any importance? I tried on other input ... same problem.

Any idea?

Thanks in advance ;-)


No sound through HDMI output - rvsixer - 07-10-2014

dpounch post=112442 Wrote:... Why movies audio is ok and not music?
Detail: the default sound of XBMC also is not playing when I switch from a category to another.
That would indicate the passthrough audio device for movie bitstreams is set up correctly.

No system sounds and no 2-ch music, is your main audio output device/number of channels set correctly (first two settings at http://wiki.xbmc.org/index.php?title=Settings/System#Audio_output).


No sound through HDMI output - dpounch - 07-10-2014

First setting is set to HDMI - VSX828 (I have the possibility to choose, two other values but they wont work)
Second setting is set to optimized.

Passthrough is checked and all the options below to enable different audio modes


No sound through HDMI output - rvsixer - 07-10-2014

Second setting should be "Number of channels", the third setting is "Output Configuration: Optimized". Set the second setting to the number of digital channels your receiver is capable of (NOT your number of speakers).

Make sure the HDMI input of your receiver is set to some type of "Auto" setting, where it can sense the audio stream coming in and output it (i.e. self adjust from a movie passthrough bitstream format to 2-ch PCM music stream, etc).

The passthrough settings only effect bitstream decoding, not 2-ch PCM as a typical music source would be.


No sound through HDMI output - dpounch - 07-14-2014

I finally manage to get some sound when playing music!
I tested several configurations and it worked with "outpu configuration" set to "fixed" and limit sample rate to 48kHz. I left all the other settings to the default config.

I still have a little problem with the xbmc default sound which is strongly distorted but I will check this later!

Thanks for your help!


No sound through HDMI output - elchue - 08-06-2014

Dear evreyone,

i've the same problem like dpounch.
My system is based on an Intel NUC Board D33217GKE with two HDMI outputs.
The Pioneer VSX-923 is connected on one of the HDMI output.
Only i could resolve this audio problem if i set the mode to fixed, but the AVR doesn't get any DTS / DD signals, only PCM.

I've tried it with OpenELEC 4.0.7 and 4.1.2
I think this problem was in early versions of OpenELEC, too.


No sound through HDMI output - rvsixer - 08-06-2014

The audio output affected by the "fixed" setting only supports PCM (you will still get DTS/DD, only xbmc will do the decoding not your AVR).

You need to enable/configure the passthrough audio device to have your AVR do the bitstream decoding:
http://wiki.xbmc.org/index.php?title=Audio_settings


Re:No sound through HDMI output - elchue - 08-07-2014

I knoe how to activate passthrough, but in fixed mode you cant enable it. Only in optimized vor best mode

Gesendet von meinem Nexus 5 mit Tapatalk


Re:No sound through HDMI output - rvsixer - 08-07-2014

elchue post=114304 Wrote:I knoe how to activate passthrough, but in fixed mode you cant enable it. Only in optimized vor best mode

Gesendet von meinem Nexus 5 mit Tapatalk
Etwas stimmt nicht ganz. Audio device output configuration (no matter fixed/best/optimized setting) is independent of passthrough audio device setting. Enable expert settings mode, enable passthrough, enable valid bitstream modes as shown in the provided wiki link. Can you post a screenshot?

FYI I have main audio device set to fixed 88.2 (for upsampled 44.1 CD music with PCM output), and passthrough device enabled for bitstreaming DTS/AC3/TrueHD/DTS-MA movies, no issues.


Scratch out my entire input. You are correct, with the audio device set to fixed, passthrough is NOT available. I had forgotten I have dual audio output setup (one device is set to fixed, the other to passthrough). My apologies.