OpenELEC Forum
Setting 24p playback outputs only Multichannel PCM - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: KODI (https://forum.openelec.tv/forumdisplay.php?fid=32)
+--- Thread: Setting 24p playback outputs only Multichannel PCM (/showthread.php?tid=72192)



Setting 24p playback outputs only Multichannel PCM - nblain1 - 07-28-2014

Hardware:
CPU: AMD Athlon (can't remember which)
MB: MSI K9N6PGM2-V
GFX: Radeon HD 5450
Openelec: Generic x86_64 Version:4.0.7 (running off USB stick)

Problem:

When I set "Adjust display refresh rate to match video" OR the setting under "System > Video output > 24p," playback works at 24p but I can no longer bitstream audio. I can only get Multichannel PCM at my receiver. The audio is in sync, so no problem there. The audio is noticeably different, and my receiver labels it as analog.

If i disable "Adjust display refresh rate to match video" and allow 60fps playback, I am able to properly bitstream all audio types to my receiver, and the receiver is able to pick up the audio types perfectly.

I have "System > Audio output > Enable passthrough" enabled with all audio types ticked.
While playing a movie I have the option "Enable passthrough" ticked as well.

I have tried enabling "System > Video Output > Vertical bank sync " to "Always" with no change.
I have tried both "Software" and "Hardware" decoding. Although I understand this is a video setting, I gave it a try.
I have tried "System > Audio output" on "Optimized," Fixed," and "Best match." None of these changed the PCM audio issue.


Has anyone else had this issue? I have searched this forum and google and found nothing. Searches are littered with "Audio Sync" issues as that is most common.

I don't have a log to post currently as someone is watching a movie on the system. I can post one later. If there is anything I left out or any additional information you may need, I will be happy to post it.

Also, if this is not in the best forum would a moderator please move it for me?

Thanks for your help!

Edit: Added Log Files (logs are from XBMC as setup now at 60hz, I will post new logs when I am able to set to 24p and try playback)


Setting 24p playback outputs only Multichannel PCM - lrusak - 07-28-2014

Yes, this is currently an issue with the amd OSS driver, there is currently nothing we can do about it.


Setting 24p playback outputs only Multichannel PCM - nblain1 - 07-28-2014

Is this in Openelec only? Would it work if i bought a hard drive and installed Windows with XBMC?

Nevermind, I just realized the OSS driver is the opensource linux amd driver.


Setting 24p playback outputs only Multichannel PCM - lrusak - 07-28-2014

Yes it probably would work on windows.


Re:Setting 24p playback outputs only Multichannel PCM - Undutchable - 07-31-2014

@Irusak; I have the same problem, which GPU doesn't have this problem?
I could put a Low Profile Video Card in my case.

(08-01-2014)
Today I got my hands on a Asus GT630 2Gb - LP, and this will never this machine again.
Lesson for me; always check compatibility of new bought parts according my standard.
As I remember, so many people loved the AMD A6-6400 because it's video capability.
But so many shortcomings according to a real Cinema Experience especially lacking DTS-HD and DTS-MA.