OpenELEC Forum
OE 4.2.1 nmap / lftp broken - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: OPENELEC ADDONS (https://forum.openelec.tv/forumdisplay.php?fid=29)
+---- Forum: unofficial OpenELEC Addons (https://forum.openelec.tv/forumdisplay.php?fid=31)
+---- Thread: OE 4.2.1 nmap / lftp broken (/showthread.php?tid=73226)



OE 4.2.1 nmap / lftp broken - JimmySmith - 10-06-2014

Hello,
I cant compile nmap and lftp in new OE version:
Code:
checking if --disable-protochain option is specified... enabled
configure: error: pcap type not determined when cross-compiling; use --with-pcap=...
configure: error: ./configure failed for libpcap

I tried add --with-pcap=linux, but I am not sure if its correct. Lftp compile seems to go somehow through, but nmap hit another error...


[attachment=1913]package_codes.zip[/attachment]


OE 4.2.1 nmap / lftp broken - ultraman - 10-07-2014

For Generic nmap compile fine with master.
Lftp needs gnutls which is no longer available. Someone must fix the package or add gnutls back..


OE 4.2.1 nmap / lftp broken - JimmySmith - 10-07-2014

Hello..
Can you post the nmap package source, which is "buildable" for you? I tried those I attached, but Ive got and errors Sad

Bad news with lftp, its more important than nmap.. I compile it somehow, but cant test build, as I didnt update from 4.0.7 yet.


OE 4.2.1 nmap / lftp broken - ultraman - 10-07-2014

https://github.com/OpenELEC/unofficial-addons/tree/master/addons/tools/nmap


OE 4.2.1 nmap / lftp broken - JimmySmith - 10-23-2014

Finally updated my RPi to 4.2.1.. You have right, 4.2.1 "compiled" lftp doesnt work. Strange, but luckilly (!!!) lftp compiled on 4.0.7 seems to be working on 4.2.1 too.

So I can use latest stable version for a while, but I am still worried of future.. (as lftp is mandatory for me = solution for non-public IP machine). I will test autossh later, when I arrive from business trip.


OE 4.2.1 nmap / lftp broken - ultraman - 10-23-2014

Seems lftp addon was removed from unofficial addon repository. So don't expect working again.


OE 4.2.1 nmap / lftp broken - JimmySmith - 02-02-2015

Sad Just testing old lftp builds on OE 5.0 and its definitivelly out of order: "missing libgnutls.so".


OE 4.2.1 nmap / lftp broken - ultraman - 02-02-2015

Try this one: https://drive.google.com/folderview?id=0B4FdVu0-fJt6YTg1TWJQTlJQWjg&usp=sharing

Don't forget to remove old zip file before installing this version - in ssh console run
Code:
rm -f /storage/.kodi/addons/packages/lftp*.zip



OE 4.2.1 nmap / lftp broken - JimmySmith - 02-02-2015

You are just the best! This one totally work on my OE 5.0.0. Thank you!