OpenELEC Forum
SickPotatoHead compatibility with Kodi - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: OPENELEC ADDONS (https://forum.openelec.tv/forumdisplay.php?fid=29)
+---- Forum: unofficial OpenELEC Addons (https://forum.openelec.tv/forumdisplay.php?fid=31)
+----- Forum: SABnzbd Suite (https://forum.openelec.tv/forumdisplay.php?fid=86)
+----- Thread: SickPotatoHead compatibility with Kodi (/showthread.php?tid=73395)

Pages: 1 2 3


SickPotatoHead compatibility with Kodi - bulo33 - 10-18-2014

Hello everyone,

SickPotatoHead is working fine with Gotham 13.2, but when I try to install it on Kodi releases (latest one is alpha 4) it is impossible to do SickPotatoHead work (all needed packages are not installed, many blocks and even loop rebooting).

Could someone comment how can I use SickPotatoHead on Kodi releases?

Thanks in advance.


SickPotatoHead compatibility with Kodi - lsellens - 11-04-2014

bulo33 post=120327 Wrote:Hello everyone,

SickPotatoHead is working fine with Gotham 13.2, but when I try to install it on Kodi releases (latest one is alpha 4) it is impossible to do SickPotatoHead work (all needed packages are not installed, many blocks and even loop rebooting).

Could someone comment how can I use SickPotatoHead on Kodi releases?

Thanks in advance.
I'm still running gotham. I'll do some testing with kodi soon. Its probably missing some python modules that are present in gotham so I'll have to include them. If you want to save me some time send me a debugging log to look at.


SickPotatoHead compatibility with Kodi - bulo33 - 11-04-2014

Thank you Isellens for your support!!!

Could you explain to me how and where can I get a debugging log file to send it to you afterwards?

FYI, I did SickPotatoHead work using the following workaround: I installed XBMC 13.2 Gotham, then I installed SickPotatoHead and finally I updated to 14.0 Helix.

Therefore your guess makes totally sense.

Looking forward to using a new SickPotatoHead version :lol:


SickPotatoHead compatibility with Kodi - lsellens - 11-05-2014

bulo33 post=121572 Wrote:Thank you Isellens for your support!!!

Could you explain to me how and where can I get a debugging log file to send it to you afterwards?

FYI, I did SickPotatoHead work using the following workaround: I installed XBMC 13.2 Gotham, then I installed SickPotatoHead and finally I updated to 14.0 Helix.

Therefore your guess makes totally sense.

Looking forward to using a new SickPotatoHead version :lol:

http://kodi.wiki/view/Log_file/Easy


SickPotatoHead compatibility with Kodi - bulo33 - 11-16-2014

Hello again,

Using OpenElec 5.0 Beta 1 (I could not use yet OpenElec 5.0 Beta 2) I tried to install SickPotatoHead.

Here you will see the only error I saw reviewing the log file. Folders into downloads folder were created succesfully, but web interfaces did not work.

[Image: SickPotatoHeadIssue_zps1f14cdbd.png]

I will try latest beta version of OpenElec to see if there is something new.

Hope it helps for developing new version Smile


SickPotatoHead compatibility with Kodi - lsellens - 11-17-2014

Sorry I've been totally slammed lately. Put a fix together real quick but I'm at work and have no way to test. Can you download and install this version for me please.
https://dl.dropboxusercontent.com/u/42265484/repository.lsellens/repo/service.downloadmanager.SickPotatoHead/service.downloadmanager.SickPotatoHead-1.4.5.zip
leave debugging on when you install it and even if it does work can you post the log for me of it running?
Also if anyone wants to help out with testing I need to test on linux based non-openelec xbmc installs (ubuntu, raspbian ect) also would like it tested on armv7l devices if anyone has one available.
Thanks in advance


SickPotatoHead compatibility with Kodi - bulo33 - 11-25-2014

Hi Isellens.

I could not try your newest version (1.4.5) however I have seen that Kodi automatically updated it, so I think it is currently stable.

CouchPotato is still working fine with my Kodi release (I'm still using the same approach I mentioned to you (Gotham + Kodi Alpha 4) but there is a problem with SickRage. When I try to connect via web interface, I'm getting the following exception:

Error

cannot find 'THEME_NAME' while searching for 'sickbeard.THEME_NAME'

Traceback

Traceback (most recent call last):
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/tornado/web.py", line 1287, in _stack_context_handle_exception return bool(etag and inm and inm.find(etag) >= 0)
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/tornado/web.py", line 1474, in wrapper """
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 239, in get raise HTTPError(404)
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 232, in _dispatch func = getattr(func(self.application, self.request), 'index', None)
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 3297, in index else:
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 553, in _munge kwargs['cacheModuleFilesForTracebacks'] = True
File "/usr/lib/python2.7/site-packages/Cheetah/Template.py", line 1010, in __unicode__
File "/storage/.kodi/userdata/addon_data/service.downloadmanager.SickPotatoHead/sbcache/cheetah/cheetah__storage__kodi_addons_service_downloadmanager_SickPotatoHead_resources_SickBeard_gui_slick_interfaces_default_home_tmpl_1416954062_8_71818.py", line 102, in respond self._handleCheetahInclude(VFN(VFFSL(SL,"os.path",True),"join",False)(VFFSL(SL,"sickbeard.PROG_DIR",True), "gui/slick/interfaces/default/inc_top.tmpl"), trans=trans, includeFrom="file", raw=False)
File "/usr/lib/python2.7/site-packages/Cheetah/Template.py", line 1615, in _handleCheetahInclude
File "cheetah__storage__kodi_addons_service_downloadmanager_SickPotatoHead_resources_SickBeard_gui_slick_interfaces_default_inc_top_tmpl_1416954064_32_78433.py", line 224, in respond
NotFound: cannot find 'THEME_NAME' while searching for 'sickbeard.THEME_NAME'

Request Info

body:
files: {}
protocol: http
connection:
body_arguments: {}
uri: /home/
query_arguments: {}
_start_time: 1416954727.27
headers: {'Accept-Language': 'es-ES,es;q=0.8,en;q=0.6,ca;q=0.4', 'Accept-Encoding': 'gzip, deflate, sdch', 'Connection': 'keep-alive', 'Accept': 'text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8', 'User-Agent': 'Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.65 Safari/537.36', 'Host': 'XXX.XXX.X.XXX:8082', 'Cookie': 'compact_display_state=false; user="2|1:0|10:1415735007|4:user|44:NWViYzFlZDJiMGY4NGM4ZWFmZDVhYTNkN2I3NDYzNmQ=|35585083ca2c50d89fac7958f9962e6559a3518d19b85cb33ce4ef652c076ee0"; manage_view2=details; advanced_toggle_checked=1; wanted_view2=details; snatched_view2=list; soon_view2=thumbs; suggestions_charts_menu_selected=charts; late_view2=list', 'Cache-Control': 'max-age=0', 'Authorization': 'Basic b3BlbmVsZWM6b3BlbmVsZWM='}
host: XXX.XXX.X.XXX:8082
version: HTTP/1.1
arguments: {}
_finish_time: None
query:
path: /home/
method: GET
remote_ip: XXX.XXX.X.XXX

Other thing it would be really nice for me to know is if this version is fully compatible with Kodi (I could not see that into the changelog file).

Thanks a lot for your work


SickPotatoHead compatibility with Kodi - lsellens - 11-26-2014

bulo33 post=123408 Wrote:Hi Isellens.

I could not try your newest version (1.4.5) however I have seen that Kodi automatically updated it, so I think it is currently stable.

CouchPotato is still working fine with my Kodi release (I'm still using the same approach I mentioned to you (Gotham + Kodi Alpha 4) but there is a problem with SickRage. When I try to connect via web interface, I'm getting the following exception:

Error

cannot find 'THEME_NAME' while searching for 'sickbeard.THEME_NAME'

Traceback

Traceback (most recent call last):
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/tornado/web.py", line 1287, in _stack_context_handle_exception return bool(etag and inm and inm.find(etag) >= 0)
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/tornado/web.py", line 1474, in wrapper """
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 239, in get raise HTTPError(404)
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 232, in _dispatch func = getattr(func(self.application, self.request), 'index', None)
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 3297, in index else:
File "/storage/.kodi/addons/service.downloadmanager.SickPotatoHead/resources/SickBeard/sickbeard/webserve.py", line 553, in _munge kwargs['cacheModuleFilesForTracebacks'] = True
File "/usr/lib/python2.7/site-packages/Cheetah/Template.py", line 1010, in __unicode__
File "/storage/.kodi/userdata/addon_data/service.downloadmanager.SickPotatoHead/sbcache/cheetah/cheetah__storage__kodi_addons_service_downloadmanager_SickPotatoHead_resources_SickBeard_gui_slick_interfaces_default_home_tmpl_1416954062_8_71818.py", line 102, in respond self._handleCheetahInclude(VFN(VFFSL(SL,"os.path",True),"join",False)(VFFSL(SL,"sickbeard.PROG_DIR",True), "gui/slick/interfaces/default/inc_top.tmpl"), trans=trans, includeFrom="file", raw=False)
File "/usr/lib/python2.7/site-packages/Cheetah/Template.py", line 1615, in _handleCheetahInclude
File "cheetah__storage__kodi_addons_service_downloadmanager_SickPotatoHead_resources_SickBeard_gui_slick_interfaces_default_inc_top_tmpl_1416954064_32_78433.py", line 224, in respond
<strong>NotFound: cannot find 'THEME_NAME' while searching for 'sickbeard.THEME_NAME' </strong>

Request Info

body:
files: {}
protocol: http
connection:
body_arguments: {}
uri: /home/
query_arguments: {}
_start_time: 1416954727.27
headers: {'Accept-Language': 'es-ES,es;q=0.8,en;q=0.6,ca;q=0.4', 'Accept-Encoding': 'gzip, deflate, sdch', 'Connection': 'keep-alive', 'Accept': 'text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8', 'User-Agent': 'Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.65 Safari/537.36', 'Host': 'XXX.XXX.X.XXX:8082', 'Cookie': 'compact_display_state=false; user="2|1:0|10:1415735007|4:user|44:NWViYzFlZDJiMGY4NGM4ZWFmZDVhYTNkN2I3NDYzNmQ=|35585083ca2c50d89fac7958f9962e6559a3518d19b85cb33ce4ef652c076ee0"; manage_view2=details; advanced_toggle_checked=1; wanted_view2=details; snatched_view2=list; soon_view2=thumbs; suggestions_charts_menu_selected=charts; late_view2=list', 'Cache-Control': 'max-age=0', 'Authorization': 'Basic b3BlbmVsZWM6b3BlbmVsZWM='}
host: XXX.XXX.X.XXX:8082
version: HTTP/1.1
arguments: {}
_finish_time: None
query:
path: /home/
method: GET
remote_ip: XXX.XXX.X.XXX

Other thing it would be really nice for me to know is if this version is fully compatible with Kodi (I could not see that into the changelog file).

Thanks a lot for your work
It should be compatible with kodi. I couldn't find anyone to give it a good thorough testing but the problem you're having I don't think is a kodi issue. I think you can fix this by editing your sickbeard config and add in the gui section theme_name = dark or theme_name = light if you prefer.
if your doing command line its
nano /storage/.xbmc/userdata/addon_data/script.service.audo/sickbeard.ini
scroll down until you see [GUI] and put the theme name below that.


SickPotatoHead compatibility with Kodi - dominic7il - 11-26-2014

I'm still on gotham and the addon appears to have updated itself overnight - I'm encountering the same missing theme error as above.


SickPotatoHead compatibility with Kodi - lsellens - 11-26-2014

dominic7il post=123464 Wrote:I'm still on gotham and the addon appears to have updated itself overnight - I'm encountering the same missing theme error as above.
did you try what i suggested above?