OpenELEC Forum
Connection lost between vdr-addon and xvdr?? - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: PVR + LIVE TV (https://forum.openelec.tv/forumdisplay.php?fid=38)
+--- Thread: Connection lost between vdr-addon and xvdr?? (/showthread.php?tid=73517)

Pages: 1 2


Connection lost between vdr-addon and xvdr?? - steppenwolf - 10-27-2014

Hi folks,

I' ve been using vdr-addon as backend and xvdr as frontend for some time now. Both vdr-addon and xvdr are installed as XBMC-addons on my Intel NUC HTPC.
In vdr-addon, I had only the sat ip-plugin enabled in order to pick up the sat>ip stream provided by my Digital Devices Octopus Net Tuner. All other vdr-addon plugins were disabled.

So far, so good - my problem:

I wanted to make use of some of the other vdr-addon plugins as well, especially the live plugin.
After activating these plugins, I suddenly got a "connection lost / no active PVR client" message by XBMC.
I tried to reestablish everything as it was before, but that didn't really help.
Deactivating / reactivating / deinstalling / reinstalling the addons and resetting their configuration also didn't help.
Best thing I achieved was that I got LiveTV back up and running, but then, after restarting my HTPC, the connection was lost again.

Even after playing around with all different possible solutions, I can't see a pattern as to when it works, what causes the connection problem and why it suddenly stops working. I'm using the current stable software versions as provided by openELEC 4.2.1.

I'm at my wits end - anybody can help me on this?

P.S. I know there have been some threads around here on the same issue. As they're all pretty old and didn't help me solve the problem, I opened a new thread.


Connection lost between vdr-addon and xvdr?? - steppenwolf - 10-28-2014

After another day of trying, I finally managed to narrow it down:

The lost connection problem is not caused by one of the vdr-addon plugins, but by setting a specific recording directory on my Synology NAS.

The NAS is connected via NFS, NFS is enabled and there is a shared folder on the NAS with an NFS permission for my home network.
I can access the folder in XBMC, i. e. the folder contents show up when I select the folder in the vdr-addon configuration as recording directory.
All seems fine, but after restarting my HTPC, I get the "connection lost" message. As soon as I reset the recording directory, things are working out again.

vdr-addon somehow can't manage the NFS share on my NAS.
What am I doing wrong here? Any clues for me? Smile


Connection lost between vdr-addon and xvdr?? - grillz - 10-29-2014

Do you have "Wait for network before starting XBMC " (Under OpenElec Settings > Network) turned on? If you don't, maybe VDR is checking the recording path before the network is fully up, so it fails.


Connection lost between vdr-addon and xvdr?? - steppenwolf - 11-03-2014

Sorry, took me some time to answer.

Activating "Wait for network" with a maximum delay of up to 60 seconds doesn't help.

If I change the "VDR Video Dir" back to a directory directly on my HTPC, the connection between vdr-addon and XVDR is reset instantly and everything works fine again. Other way round, the connection is lost as soon as I change it to a directory on my NAS. The NAS is constantly on the network and otherwise accessible from the HTPC (i. e., the shared folders from the NAS, their subfolders and contents show up under XBMC).

I don't know if any of the other vdr-addon-options could help - I don't find any documentation, especially for "Enable external recdmd", "Wait for frontend initialization", "Unload DVB modules before suspend".

Additionally, I have a 4 tuner-device supplying 4 separate sat>ip-streams, but only one seams to be picked up by vdr-addon: If I activate more than one timers simultaneously, I get a timer conflict.

PLEASE help me on this - I can't use openELEC properly if I don't get this solved!
Thanks in advance!


Connection lost between vdr-addon and xvdr?? - grillz - 11-03-2014

Is there anything in your xbmc log file (I believe that is where vdr logs to) about a failed attempt to connect to the NAS? You should probably post your log file.


Connection lost between vdr-addon and xvdr?? - steppenwolf - 11-04-2014

There seem to be a couple of errors in the xbmc.log, please have a look.
I myself can't see anything what should be wrong with either the NAS, the network connection and the general HTPC / openELEC / XBMC setup.

Thing is, if I don't get the NAS connection working, I can't use the HTPC, since I only have a small SSD on the HTPC.

Thanks a lot for your help, man!


Connection lost between vdr-addon and xvdr?? - grillz - 11-04-2014

The vdr plugin certainly seems to be having an issue reaching the nfs folder (in the Journal-cur.log):
Nov 04 18:18:13 HTPC sh[686]: /bin/sh: can't open '/storage/.config/autostart.sh'
Nov 04 18:18:13 HTPC vdr[685]: [685] ERROR (tools.c,441): nfs [ip and folder path]: No such file or directory
Nov 04 18:18:13 HTPC sh[685]: vdr: can't access video directory nfs [ip and folder path]
Nov 04 18:18:13 HTPC systemd[1]: service.multimedia.vdr-addon.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Nov 04 18:18:13 HTPC systemd[1]: Unit service.multimedia.vdr-addon.service entered failed state.

Have you tried mounting the nfs folder (Mounting Network Shares) and then pointing the "VDR Video Dir" at that mount point?


Connection lost between vdr-addon and xvdr?? - steppenwolf - 11-04-2014

Ok... I created a new file autostart.sh as described in the wiki entry you told me.

I followed the "old method".
The autostart.sh contains the following code:
#!/bin/sh
(sleep 30;
mount -t nfs 192.168.178.26:/volume1/Aufnahmen /storage/Videos -o nolock;
)&


192.168.178.26 being the NAS IP, /volume1/Aufnahmen is the shared directory on the NAS.
The path under VDR Video Dir is "nfs://192.168.178.26/volume1/Aufnahmen".
/storage/Videos is an existing directory on my HTPC where I'd like to mount the NAS directory.

After restarting the HTPC, I don't see any difference.

I attached the current log files - maybe that helps.


Connection lost between vdr-addon and xvdr?? - grillz - 11-05-2014

if you ssh into openelec and go to /storage/Videos does it show folders/files found on the NAS?

If yes, set the path under VDR Video Dir to /storage/Videos.

If no, try the suggestions under "Nothing happends" from the wiki entry to see if you get any errors.


Connection lost between vdr-addon and xvdr?? - steppenwolf - 11-05-2014

Ok... the "videos" directory only shows two recordings, but these are both physically on the HTPC SSD, not on the NAS.

Doing the "Nothing happens" as you told me (i. e. starting the mount command from SSH), I get a "Remote system error - Connection refused" error stating that mounting failed due to a bad file descriptor.

Forgive me for being such al Linux newbie :-|