OpenELEC Forum
No sound through HDMI on Shuttle - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: No sound through HDMI on Shuttle (/showthread.php?tid=76082)



No sound through HDMI on Shuttle - madsk - 03-21-2015

Hi guys

After a long time of using XBMC 13.1 on my Windows 8.1 HTPC I decided that I wanted to use Openelec instead because the machine seemed a bit slow and lagging in menus etc.

I've just installed the latest Openelec (5.0.6) on my Shuttle DS81, but I'm having an issue with the audio.

The HTPC is connected to my Sony receiver with a 5.1 audio system, but when i choose HDA Intel, HDMI #0 from the list and the same option under Passthrough, I get no sound.

I have the following options available in the list

HDA Intel, HDMI #0
HDA Intel, SNY #1
HDA Intel, HDMI #2
HDA Intel PCH, ALC892 Analog
HDA Intel PCH, ALC892 Digital S/PDIF

I'm not sure which one to choose other than the HDMI which to me was the most obvious one. I'm wondering if I need to update some drivers or do something else before I can make this work?

I would really appreciate some help on this matter.

---

A bit of extra info

I'm using a Intel® Core™ i5-4570S with HD4600

EDIT:

So I've tried the "HDA Intel, SNY #1", which I have no idea what is and that seems to give audio. However when I chose this option in pass-through a lot of the options like DTS-HD etc. disappear. So I'm not sure this is solved. If I choose HDMI I get a bunch of options that I can enable for my receiver.


No sound through HDMI on Shuttle - madsk - 03-23-2015

Decided to go back to Windows since that worked and apparently no one knew a solution to the problem.


No sound through HDMI on Shuttle - madsk - 03-23-2015

Duplicate.