OpenELEC Forum
Display flickers on Chromebox - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: DISPLAY (https://forum.openelec.tv/forumdisplay.php?fid=59)
+--- Thread: Display flickers on Chromebox (/showthread.php?tid=76627)



Display flickers on Chromebox - vanadium2 - 04-25-2015

Hi All,

I've just setup a brand new Asus Chromebox running OpenELEC 5.0.8 (x86_64). I've got an HDHomeRun Prime setup to record with MythTV v0.27.4-46. I've configured Kodi with the MythTV PVR add-in and have live and recorded TV working.

The problem I face however is related to the playback. When watching either live or recorded TV I see a constant "flicker". The audio and video are playing but the display goes between black and a picture at a fairly fast interval (multiple times per second). The Kodi UI does not flicker only the underlying video. I consistently see this problem when watching standard definition TV. I only occasionally see it when watching HD (1080p) content (although it does still happen). I also have Kodi installed on a Windows PC and playback is flawless of the same content hooked up to the same MythTV instance.

I've tried as many different resolution/sync rates as possible and none of the change the behavior. I've configured hardware acceleration per the guide on the kodi wiki (disable VDPAU, enable VAAPI).

I have tried hooking my Chromebox up to multiple TVs and computer monitors and I have the same experience with all of them. I thought perhaps it could be network related so I've tried on both wired and wireless networks with no noticeable difference.

I'm at a loss -- any suggestions before I shit can this thing?

Output from xrandr

http://sprunge.us/aAdO


Display flickers on Chromebox - nickr - 04-27-2015

Do you have "adjust display refresh rate to match video" turned on?

Also what frame rate is your TV being broadcast at?
Does this happen on non PVR material?


Display flickers on Chromebox - vanadium2 - 04-27-2015

File stored on an SMB share (over the network) playback fine without flicker.

I've tried with and without the "adjust display refresh rate to match video" setting with no noticeable impact. I've tried connected to my Samsung LCD and to a Dell 4k monitor. Both have produced the same result. I'm only trying to get output at 1080p (60hz).

Any other ideas? I thought it could be a MythTV issue but the recordings are fine. I can playback via Kodi on my Windows PC without issue.


Display flickers on Chromebox - vanadium2 - 04-27-2015

Also -- if I watch my HDHomeRun Prime directly via the HDHomeRun Add-on there is no flicker. The flicker only comes in when watching via the PVR add-on (and the recorded content).


Display flickers on Chromebox - nickr - 04-27-2015

What frame rate is your TV being broadcast at?


Display flickers on Chromebox - nickr - 04-27-2015

Also check you have all the recommended settings (including the deinterlace settings) from http://kodi.wiki/view/Chromebox#Recommended_Settings


Display flickers on Chromebox - chrome619 - 07-22-2015

Hi, I'm also experiencing the same issue as OP.. Was there a solution to this?