OpenELEC Forum
Openelec Does not recognize External HDD 3.5" - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: STORAGE (https://forum.openelec.tv/forumdisplay.php?fid=60)
+--- Thread: Openelec Does not recognize External HDD 3.5" (/showthread.php?tid=76699)

Pages: 1 2 3


Openelec Does not recognize External HDD 3.5" - Rok3r88 - 05-02-2015

Hi all,
Rpi model B won't read my external HDD 3.5" NTFS 1TB, it's working well on windows. Plug on RPI and nothing appears.
The box is Fantec ALU3-6g
Thanks.


Openelec Does not recognize External HDD 3.5" - dhutch85 - 05-03-2015

Has it been mounted? Kodi should auto-mount it from my experience. You can check this by looking at the storage menu in settings. If you can see it listed it should then have mounted to /var/media/ in the root file system.


Openelec Does not recognize External HDD 3.5" - Rok3r88 - 05-03-2015

Hi, The hdd is not mounted, on system info i can see only the SD Card, /var/media is empty.
But when i turn off the hdd, openelec show the popup "peripheral disconnected""
Thanks


Openelec Does not recognize External HDD 3.5" - dhutch85 - 05-03-2015

Rok3r88 post=139142 Wrote:Hi, The hdd is not mounted, on system info i can see only the SD Card, /var/media is empty.
But when i turn off the hdd, openelec show the popup "peripheral disconnected""
Thanks

How is the hard drive connected to the Pi? Do you get a message when you first connect the hard drive to the Pi?

When mine is connected is appears in system -> system info -> storage
also in system -> file manager
and also video -> files (from the main menu based on the default skin)

You could try SSH into your Pi and try the mount command (you will need to enable SSH in options). The message on screen when the mount command is run should tell you if the drive has mounted or not and where too. run mount without the drive connected then once again with it connected.


Openelec Does not recognize External HDD 3.5" - Rok3r88 - 05-04-2015

The Hard drive is connected by external box "fantec alu3e" with a cable usb3.
When i connect the HDD i have no message, nothing appear.
on system info-storage i have only the sd card.
OK ssh enabled, which is the command "mount"? im noob of linux


Openelec Does not recognize External HDD 3.5" - dhutch85 - 05-04-2015

Not sure why it isn't picking up if the hard drive is powered by mains. USB 3.0 is backward compatible with 2.0 so can't see that being the issue either.

For SSH read this http://wiki.openelec.tv/index.php/Ssh_commands

Use Putty on another computer, SSH into your Pi then use the mount command before and then after the hard drive is connected.


Openelec Does not recognize External HDD 3.5" - Rok3r88 - 05-05-2015

I think the hdd must be SDA1, is the only storage i have.
Mount with hdd OFF:
mkdir /media/hdd
mount /dev/sda1 /media/hdd
mount: mounting /dev/sda1 on /media/hdd failed: No such file or directory.

When i turn ON the hdd:
mount /dev/sda1 /media/hdd
mount: mounting /dev/sda1 on /media/hdd failed: Invalid argument

I think the box is incompatible , on windows work well.


Openelec Does not recognize External HDD 3.5" - dhutch85 - 05-05-2015

The hard drive should mount to SDA1 yes.

Does look it isn't compatible for some reason but I can't find a list of compatible external hard drives to point you too. Have you got a spare usb memory stick you can use just for testing?

What file system is the HDD? Someone else had the mounting /dev/sda1 on /media/hdd failed: No such file or directory error message in this thread and it turned out to be an issue with how the drive had been formatted.


Openelec Does not recognize External HDD 3.5" - nickr - 05-05-2015

What we really need is the output of dmesg when you plug the disk in.

Reboot
SSH in
plug in the external drive
In ssh shell run
Code:
dmesg|paste
post back here the url that the paste command returns.


Openelec Does not recognize External HDD 3.5" - Rok3r88 - 05-05-2015

This is,
http://sprunge.us/SGMd

Thank you