OpenELEC Forum
Network Mount does not remount upon startup - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: STORAGE (https://forum.openelec.tv/forumdisplay.php?fid=60)
+--- Thread: Network Mount does not remount upon startup (/showthread.php?tid=76951)



Network Mount does not remount upon startup - rjbathgate - 05-22-2015

HI

I followed this wiki: http://wiki.openelec.tv/index.php?title=Mounting_network_shares

and ended up with:

File: storage-recordings.mount

Contents:

Code:
[Unit]
Description=Mount ReadyNAS Recordings
Requires=network-online.service
After=network-online.service
Before=kodi.service

[Mount]
What=192.168.1.10/data/Recordings
Where=/storage/recordings
Options=
Type=nfs

[Install]
WantedBy=multi-user.target

However to then go and mount it, when I run:

Code:
systemctl enable storage-recordings.mount

It does nothing; it returns no errors, however the drive is not mounted.

However running the following command manually does result in a successful mount:

Code:
mount -t nfs 192.168.1.10:/data/Recordings /storage/recordings -o nolock

So...
1) Any idea where I can start looking so that systemctl enable storage-recordings.mount works?
and
2) Once this works, will this automount it on device start up?

At the mount every time the device starts up I have to manually run the mount command.

Any pointers, most appreciated.

Thanks


Network Mount does not remount upon startup - klojum - 05-22-2015

Do you really need manually edited mounts?
Just for files access, set up your Kodi via shares via the GUI:
http://kodi.wiki/view/Video_management#Adding_media_sources


Network Mount does not remount upon startup - lrusak - 05-22-2015

Code:
systemctl enable storage-recordings.mount
simply enables the mount to be used next time the system is booted
Code:
systemctl start storage-recordings.mount
will mount it right away
Code:
systemctl status storage-recordings.mount
will check if it mounted successfully.


Network Mount does not remount upon startup - nikstra - 05-22-2015

There is a colon missing from
Code:
What=192.168.1.10/data/Recordings
It should be
Code:
What=192.168.1.10:/data/Recordings

Use the journalctl command to view system logs.


Network Mount does not remount upon startup - rjbathgate - 05-23-2015

Hi

Quote:Do you really need manually edited mounts?
Yes, needed for things outside of Kodi (Tvheadend PVR for example)

It was the missing colon:
Code:
What=192.168.1.10:/data/Recordings

Fixed that, then reran:
Code:
systemctl enable storage-recordings.mount

Then on reboot it mounted successfully.

Many thanks for all your help
Cheers