OpenELEC Forum
transferring files to openElec - SFTP - hangs - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: MISCELLANEOUS (https://forum.openelec.tv/forumdisplay.php?fid=23)
+--- Thread: transferring files to openElec - SFTP - hangs (/showthread.php?tid=77254)



transferring files to openElec - SFTP - hangs - MikeP - 06-19-2015

Hi folks - when using SFTP to transfer files (movies) to my OpenElec system from another PC it will hang after a few minutes - usually after about 1G is transferred. The only way I've found to recover is to reboot the system - restarting SSH doesn't seem to help. Oddly enough I can still get in using SSH or by going over to the TV the system seems ok, but there's no way to get the data transferred. I had a similar issue using samba - seemed even worse - so that's not an alternative.

If I boot this same system under stock ubuntu I can transfer many gigabytes of data over SFTP the same way with no problem.

Am I doing something wrong?

BTW, I also found that if I left the screen saver running for a few days OpenElec will hang, and occasionally it will not restart properly on reboot. Not sure if this is related.


transferring files to openElec - SFTP - hangs - klojum - 06-19-2015

Have to ask... There is enough storage space left for the transferring file(s)?

"The" screensaver.. Which one is that?
Personally I never use screensavers.
But if your screensaver hangs, other things might hang too.
Disable your screensaver before copying files.


transferring files to openElec - SFTP - hangs - MikeP - 06-19-2015

Fair questions, thanks for following up.

Yep, tons of room on the OpenElec system on my media drive, when I reboot back to Ubuntu the stalled file and then many more complete without any problem. That drive is not shared on the network and samba is disabled.

Not sure where the screen savers came from, I think they were installed as the basic set of official addons? I tried 2 or 3 of the pattern choices before realizing it was the problem, freezing every day or two. Now I don't use a screen saver either and I've never found OpenElec frozen/stuck even after many weeks of continuous operation. SFTP still hangs.

Mike