OpenELEC Forum
Creative Labs SB0530 Audigy 2 ZS Driver - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: Creative Labs SB0530 Audigy 2 ZS Driver (/showthread.php?tid=77518)



Creative Labs SB0530 Audigy 2 ZS Driver - Pikmin - 07-15-2015

Hey everyone
I was hoping to get this device working in OpenElec, however lspci doesn't detect it at all.
In Ubuntu 15 shows up as
Multimedia audio controller: Creative Labs SB0400 Audigy 2 Value
Subsystem: Creative Labs Device 2001
Kernel driver in use: snd_emu10k1

I have compiled OpenElec from source before, would I just need to include emu10k1 driver?

One other thing I don't quite get- If I get it working in 5.0 when I update to anything newer it loses the driver, how would I get OE to keep the driver


Creative Labs SB0530 Audigy 2 ZS Driver - chewitt - 07-16-2015

You need to self-build to add the driver. Once that's done.. periodically "git pull" and checkout the newer branch that you want to build.. and build again. If this is a modern/recent soundcard device you're welcome to submit a pull request to add it to the core build. If it's an older (aka ancient) card you can keep it too yourself Wink


Creative Labs SB0530 Audigy 2 ZS Driver - chewitt - 07-16-2015

NB: OE does not "install" itself.. it boots from 2x files (KERNEL/SYSTEM). If you self-build those you have the driver. When you update to anything official you have our files without the driver.