OpenELEC Forum
PXE Boot stopped working with Kernel 4.1.1 - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: NETWORK (https://forum.openelec.tv/forumdisplay.php?fid=49)
+---- Forum: PXE / Network boot (https://forum.openelec.tv/forumdisplay.php?fid=50)
+---- Thread: PXE Boot stopped working with Kernel 4.1.1 (/showthread.php?tid=77630)



PXE Boot stopped working with Kernel 4.1.1 - chrisk2305 - 07-25-2015

Hi there,
If have been using PXE/TFTP Boot for the last 6 month without any issues but since I upgraded my Kernel (Server side) to 4.1.1 it stopped working. When I try to boot via Network the Kernel loads fine but then stops when trying to mount the NFS Share. I get the error: Error in mount_flash , Could not mount 192.168.1.2:/mnt/bla
Network works fine though. Then I booted another linux live cd and tried to mount the NFS Share manually which also worked.

After checking various settings, I compiled a new kernel version (4.1.2) with the exact same options and voila the system boots again over network. Last night I upgraded to Kernel 4.1.3 and network boot failed again with the above error. Any Idea what the issue is? Is this just a bug in the kernel?

Thanks in advance,
Christian