OpenELEC Forum
Some 5.1 audio functions missing from Helix? - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: Some 5.1 audio functions missing from Helix? (/showthread.php?tid=78119)



Some 5.1 audio functions missing from Helix? - fuzzweed - 09-08-2015

Just doing a trial run with OE5 / Helix live from a USB stick to see what works / doesn't work compared to my installed and stable Frodo setup.
Main things missing seem to be support of multichannel audio:
1) AAC 5.1 transcoding to DD: I have an AC3 amplifier connected via optical cable that would play discrete 5.1 DD from UK HD freeview on Frodo. With Helix freeview HD broadcasts are detected as 5.1 by Kodi, but I'm only getting 2 channel sound at the amplifier. All the options I'm familiar with which used to select (e.g) AC3 capable amplifier have disappeared from audio settings. My only relevant options seem to be whether to use passthrough, or whether to use stereo upmix. Neither of these options has any change to the output.

2) DTS passthrough: Any DTS source I have (mostly backed up DVDs) is output via optical cable as 2 channel, even with pass through selected. Again option for selecting DTS capable receiver is no longer available.

Have searched various forums and have some clues, but nothing 100% relevant to my situation. Hope someone can clarify if I'm able to fix this situation, or if I'm stuck with Frodo.

Thanks.


Some 5.1 audio functions missing from Helix? - chewitt - 09-08-2015

enable Advanced or Expert mode in Kodi settings (bottom left in settings GUI)


Some 5.1 audio functions missing from Helix? - fuzzweed - 09-08-2015

Yes, did this but neither those specific options or anything more helpful is revealed.


Some 5.1 audio functions missing from Helix? - Serbig - 09-10-2015

Hi! I don't mean to hijack your thread, but I've got a similar problem with Openelec versions 5.0.8 and 5.9.5.

I used RPis in the past and switched to the RPi 2 as soon as it came out. Until yesterday, I still had Openelec 5.0.1 installed on my RPi 2 and AC3/DTS passthrough worked just as it had on my first RPis (HDMI passthrough to a little converter box that passes on the audio/video signals via HDMI to my TV as well as extracts the audio signal and sends it via toslink to my old Sony AV receiver.

Yesterday, I updated to 5.9.5 and noticed that AC3 passthrough doesn't work anymore. As soon as I play a file with 5.1 ac3, the display on my AV receiver tells me that it receives a 2.0 signal, but there's no sound.
I then downgraded to 5.0.8 (I figured that the last stable release should be more or less bug free). The display still tells me that it gets a 2.0 signal, but at least the receiver also plays the 2.0 audio.
DTS still works on both versions.

Is there something I can do/activate to get AC3 5.1 surround sound working again?


Some 5.1 audio functions missing from Helix? - fuzzweed - 09-10-2015

Kind of glad that others are experiencing similar problems, it reduces the likely hood that it's system specific to me!
The only other reference I can find to the problem is that Kodi changed to using PulseAudio in stead of Alsa for sound management, although it also states in the same thread that embedded systems (which I'm guessing includes OE?) still use Alsa.
Would be grateful if someone more knowledgeable about this could let me know if this is a likely cause, and if OE is using Pulse, how to restore it to using Alsa.


Some 5.1 audio functions missing from Helix? - Serbig - 11-12-2015

I know this is an old thread, but I'm still encountering some audio problems.

After having serious issues with Openelec 5.0.8 and 5.95, I reverted to 5.0.5 for a while.
Since Openelec 6.0 was released, I was really feeling the urge to give it a try, but I fought the urge because I was afraid something would break. Well, a few minutes ago, I felt lucky and had some spare time on my hands, so I upgraded to version 6.0.

But guess what: Yeah, AC3 passthrough still doesn't work. My AV receiver says that it gets a Dolby Digital signal and shows all of the channels, but it just won't play a sound. DTS still works fine though.

What can I do to get Dolby Digital running on my RPi 2 with Openelec 6.0?


Re:Some 5.1 audio functions missing from Helix? - nickr - 11-12-2015

debug log

Sent from my U65GT using Tapatalk