OpenELEC Forum
iperf 3.x? - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: OPENELEC ADDONS (https://forum.openelec.tv/forumdisplay.php?fid=29)
+---- Forum: unofficial OpenELEC Addons (https://forum.openelec.tv/forumdisplay.php?fid=31)
+---- Thread: iperf 3.x? (/showthread.php?tid=78395)



iperf 3.x? - ronbaby - 10-01-2015

I just installed the the unofficial iperf add-on onto my OpenELEC/HTPC box. It is reporting a version number of 2.0.5, and apparently does not wish to play well with the iperf client that I just now downloaded onto my Windows7 box from the official iperf web site... I guess because that is the (incompatible) iperf version 3.

So, just curious... Does the maintainer of the OpenELEC iperf add-on... whoever that is... have any plans to update that to 3.x?


iperf 3.x? - hughparker1 - 11-05-2015

ronbaby post=148893 Wrote:I just installed the the unofficial iperf add-on onto my OpenELEC/HTPC box. It is reporting a version number of 2.0.5, and apparently does not wish to play well with the iperf client that I just now downloaded onto my Windows7 box from the official iperf web site... I guess because that is the (incompatible) iperf version 3.

So, just curious... Does the maintainer of the OpenELEC iperf add-on... whoever that is... have any plans to update that to 3.x?
I had a similar problem when testing wi-fi adapter speeds on my Raspberry Pi, when using my windows computer as server, didn't work, so I used my old linux laptop and installed iperf using synaptic package manager. And was able to get it to work
Code:
iperf -c # enter this in PuTTY terminal ssh to client (RPi) connected to router via wi-fi

iperf -s # enter this in terminal on server connected to your router via LAN cable

... although the output looks to be in correct format, I found that normal command prompt is not displayed when it finished, so I can't run the same command again, I need to close PuTTY and open it again if I want to run the command again. Also found the values returned to be quite a bit higher than I expected, 55.6 Mbits/sec on the RPi , versus 18.8 Mbits/sec during test on my laptop client. I didn't expect both to be the same but didn't think there would be such a big difference since both are using a standard 802.11n wireless adapter.
hope this helps.


Re:iperf 3.x? - Gaudi - 11-12-2015

I second the request for an updated addon version with new iperf version, iperf3.
I have a couple of routers and the 3rd party firmware I am using has this new version included.

Thanks