OpenELEC Forum
No vídeo on mkv playback - Printable Version

+- OpenELEC Forum (
+-- Forum: Generic Forum (
+--- Forum: VIDEO DECODERS (
+--- Thread: No vídeo on mkv playback (/showthread.php?tid=79075)

Pages: 1 2

No vídeo on mkv playback - Cowboybebop - 12-01-2015

Hello everybody.

I tried to search and i search em alot for the problem that i have.

I have built an htpc.
Here the specs of it

Amd a6-6400k
Asrock a88x itx
4gb ddr3
128gb ssd
2tb hdd (with alot of movies)
Antec isk 600
450w psu

I always used kodi on a macbook and it works perfectly. Now, i have built this htpc and when i try to play a transfered mkv from the ssd it doesn't give me any possibility to choose audio, subtitles and doesn't show any image. Only audio.

Everything works perfectly. Bluetooth, wifi, Internet. Just doesn't detect the 2tb hdd and i'm unable to Add a Computer with shared folder. But that's another story to solve.

Thank you for your attention on this matter.

Enviado do meu A0001 através de Tapatalk

No vídeo on mkv playback - klojum - 12-01-2015

OE should detect any internal and external drives, unless there is some problem with the drive(s).
if you can go into a SSH session and connect to your AMD htpc, execute the following commands:
blkid | pastebinit
mount | pastebinit

Paste both the URLs here so we can have a look.

No vídeo on mkv playback - Cowboybebop - 12-02-2015

klojum, this is what came out

btw any tip on the video image nof mkv files?

No vídeo on mkv playback - Cowboybebop - 12-02-2015

after investigating a way to mount the hdd that i found on the first pastbin this is the output:

mount -t ntfs /dev/sdb5 /mnt
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb5': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
mount: mounting /dev/sdb5 on /mnt failed: No such file or directory

i don't understand why because before removing the hdd from the other computer i shutdown correctly the computer...
what an headache if i have to dismount, reattach to computer with windows, dismount and mount on the htpc...

than you

No vídeo on mkv playback - chewitt - 12-02-2015

This is a design and ethos difference between Windows and Linux. Windows favours user convenience and ignorance so drives are mounted regardless of state and the first you know of something being screwed up is when it completely fails. Linux warns you immediately and either won't mount the drive or will mount read-only to prevent further damage to the filesystem. It may simply be a sign of Windows not shutting down properly, but these types of errors are frequently a sign of a drive falling sick too. Perhaps consider making a backup and either do a clean wipe and restore of the drive from backup or figure out why Windows doesn't do clean shutdowns.

No vídeo on mkv playback - Cowboybebop - 12-02-2015

i have found a solution. for it i will apply it later if possible "sudo ntfsfix /dev/sdb5" from what i've read, this should fix and mount with no problem.

Windows 8 and so on have the function to turn windows on or off faster and it must be disabled.

No vídeo on mkv playback - Cowboybebop - 12-02-2015

And the comand doesn't work...

Tried "sudo ntfsfix /dev/sdb5" and this is what came out:
"There is no working 'sudo'.

On debian/ubuntu/all general purpose linux distributions 'sudo'
allows a permitted user to execute a command as the superuser
or another user, as specified by the security policy

With OpenELEC you have root access by default, so you dont need 'sudo'"

tried without sudo and doesn't recognise ntfsfix command

Any idea?


tried redering by software the mkv and didn't worked!!

No vídeo on mkv playback - Cowboybebop - 12-02-2015

i don't get it...

i have changed to detect network before booting.

after that the upnp server ps3 media server works flawless. even the mkv files now work perfectly. image, sound, subtitles...
it's one of those things that make me ultra expert in computer sicence without even knowing anything about it.. Tongue Tongue Tongue

No vídeo on mkv playback - chewitt - 12-03-2015

The "wait for network" option doesn't actually wait for the network, it simply delays Kodi start by X seconds. It sounds like the device mounts slowly.. so waiting a little allows something to complete properly. The sudo error is self-explanatory and ntfsfix is not embedded in OE so you need to resolve NTFS issues in Windows before safely ejecting and connecting to OE.

Re:No vídeo on mkv playback - Cowboybebop - 12-05-2015

Solved the problem. Of the hdd.
Made a live Linux puppy USB. And fixe d the ntfs of the hdd. Now I just need to. Solve. Why. Hd streams are not shown on Genesis, primewire and Phoenix... It just scraps for dvd quality

Enviado do meu A0001 através de Tapatalk