OpenELEC Forum
Cracking sound via HDMI - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: Cracking sound via HDMI (/showthread.php?tid=80756)



Cracking sound via HDMI - thuree - 03-27-2016

Hello all,

I've recently built an OpenELEC box and all is working lovely however...

I get crackling sounds during playback of streaming or local files within Kodi. If I bring up the OSD/menu system the cracking disappears.

I'm outputting audio to my TV using HDMI and I understand the following change to the default.pa file will fix things.

Changing:
Code:
load-module module-udev-detect

To:
Code:
load-module module-udev-detect tsched=0

I've connected to my OE device with SSH using the root user but the default.pa file is read-only.
Nano will let me view the file but not changes can be written. There is no SUDO so I'm stuck on where to go next... CHMOD doesn't work either.

Does anyone have an idea to how I can make this file writable? Even if only temporarily.
Or, does anyone have an alternative fix to my crackling problems other than using the headphone jack on the computer.

Kind Regards
Arran


Cracking sound via HDMI - islipfd19 - 03-28-2016

thuree post=160903 Wrote:Hello all,

I've recently built an OpenELEC box and all is working lovely however...

I get crackling sounds during playback of streaming or local files within Kodi. If I bring up the OSD/menu system the cracking disappears.

I'm outputting audio to my TV using HDMI and I understand the following change to the default.pa file will fix things.

Changing:
Code:
load-module module-udev-detect

To:
Code:
load-module module-udev-detect tsched=0

I've connected to my OE device with SSH using the root user but the default.pa file is read-only.
Nano will let me view the file but not changes can be written. There is no SUDO so I'm stuck on where to go next... CHMOD doesn't work either.

Does anyone have an idea to how I can make this file writable? Even if only temporarily.
Or, does anyone have an alternative fix to my crackling problems other than using the headphone jack on the computer.

Kind Regards
Arran

You can try this:

1. create a file called pulse-01.conf in directory '/storage/.config/pulse-daemon.conf.d' and add the following
default-script-file = /storage/default.pa
2. create file default.pa in '/storage/default.pa' and add 'load-module module-udev-detect tsched=0' and save.
3 reboot and see if it fixes your issue

The README file in '/storage/.config/pulse-daemon.conf.d' explains how the config files are handled.


Cracking sound via HDMI - Santa666 - 09-13-2016

I have the same problem with my.Shuttle SG31G2 and Yamaha rx-v765 and i have tried all kodi settings, did you find the cause of the problem?