OpenELEC Forum
TBS6985 & Sony Play Tv Tuner - No signal on resume - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: PVR + LIVE TV (https://forum.openelec.tv/forumdisplay.php?fid=38)
+--- Thread: TBS6985 & Sony Play Tv Tuner - No signal on resume (/showthread.php?tid=80775)



TBS6985 & Sony Play Tv Tuner - No signal on resume - Keysersose12 - 03-28-2016

I'm using tvheadend along with two tbs 6985 tuners and one Sony play tuner and is working fine. However i now would like to get suspend and resume working.

I'm using cvh's crazycat builds and have added this to the tvheadend settings but have had no luck (order makes no difference). Channels dont work when the pc resumes. PC suspends ok.

<setting id="REMOVE_MODULES" value="dvb_usb_dib0700,saa716x_tbs_dvb" />


Anyone have an idea how to fix this?


TBS6985 & Sony Play Tv Tuner - No signal on resume - Keysersose12 - 03-28-2016

this is what i see with lsmod

OpenELEC:~ # lsmod
Module Size Used by
rc_dib0700_rc5 2220 0
tbsfe 993 8
tbs6985fe 14111 8
fuse 63243 3
ir_lirc_codec 3893 3
lirc_dev 7851 1 ir_lirc_codec
snd_hda_codec_generic 44011 1
ir_mce_kbd_decoder 3663 0
ir_sony_decoder 1819 0
ir_jvc_decoder 1945 0
dvb_usb_dib0700 110189 2
dib9000 22600 1 dvb_usb_dib0700
dib8000 25036 1 dvb_usb_dib0700
dib7000m 12365 1 dvb_usb_dib0700
dib0090 19293 1 dvb_usb_dib0700
dib0070 6939 3 dvb_usb_dib0700
dib7000p 22474 3 dvb_usb_dib0700
dib3000mc 9552 1 dvb_usb_dib0700
rc_tbs_nec 1140 0
dibx000_common 5748 6 dib8000,dib9000,dvb_usb_dib0700,dib3000mc,dib7000m,dib7000p
dvb_usb 15748 1 dvb_usb_dib0700
ftdi_sio 35577 0
usbserial 18562 1 ftdi_sio
snd_hda_codec_hdmi 31854 1
intel_rapl 8444 0
iosf_mbi 2594 1 intel_rapl
intel_powerclamp 6982 0
ir_rc6_decoder 2457 0
saa716x_tbs_dvb 68757 0
ir_rc5_decoder 1881 0
snd_hda_intel 19393 3
saa716x_core 32275 4 saa716x_tbs_dvb
snd_hda_controller 14763 1 snd_hda_intel
stv090x 44239 1 saa716x_tbs_dvb
snd_hda_codec 66065 4 snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
ir_nec_decoder 2201 0
dvb_core 73432 6 dib8000,dib9000,saa716x_core,dvb_usb,saa716x_tbs_dvb,dib7000p
rc_core 12715 15 ir_lirc_codec,ir_rc5_decoder,dvb_usb,ir_nec_decoder,ir_sony_decoder,rc_tbs_nec,saa716x_tbs_dvb,dvb_usb_dib0700,rc_dib0700_rc5,ir_mce_kbd_decoder,ir_jvc_decoder,ir_rc6_decoder
snd_hda_core 14050 4 snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_controller
snd_hwdep 4699 1 snd_hda_codec


TBS6985 & Sony Play Tv Tuner - No signal on resume - bam - 03-29-2016

I have similar issue, but workaround is to change channels manually after resume (last one before suspend can't start automatically). It's not a solution for me, so I have to switch off suspension, leaving just TV off instead


TBS6985 & Sony Play Tv Tuner - No signal on resume - Keysersose12 - 03-29-2016

Thanks for the response, unfortunately for the tbs 6985 anyways any channel i've tried gets no singal. I messed about with scripts for unloading and loading modules and the play tv tuner seems to work most of the time after restart but not the case for the tbs tuners.


TBS6985 & Sony Play Tv Tuner - No signal on resume - bam - 03-29-2016

Then, it is another issue.
Unfortunately, it seems suspension work rather unstable in OE - for example, after resume, I loosing IP network connection over WiFi in my last beta OE installation
EDIT:
The suspension not that "unstable" in OE but breaks between versions sometimes