OpenELEC Forum
Acer Revo R3700 sound problems. - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: Acer Revo R3700 sound problems. (/showthread.php?tid=8251)



[SOLVED] Acer Revo R3700 sound problems. - banjo1891 - 07-14-2011

Hi All.

I'm hoping one of you clever people can help me. I recently bought an acer revo R3700 and installed openelec on an 8gb usb stick. Overall I'm extremely impressed with it. It plays every audio and video format I've thrown at it and runs extremely smoothly. Unfortunately I'm having a nightmare configuring the sound output.
I have logitech x530 5.1 speakers connected to a cheap, 5.1 c-media usb sound card, plugged into the Revo's sp/dif output. The revo is connected to the tv via hdmi. My audio settings in xbmc are:

Audio Output: Optical/Coax
Speaker Config: 5.1
Audio Output Device: USB sound device iec958
Passthrough output device: USB sound device iec958

Using this configuration playback of video and music from my external hdd is fine. I get 5.1 sound with my 5.1 movies and stereo playback from all other sources. I have tried many other configurations, after trawling forums such as this, but most of them return the "failed to initialise audio device" message.The main problem I am experiencing is with flash video, primarily youtube.

Some videos play absolutely fine but many play far too fast, so any voices sound like the chipmunks. I am a complete novice with linux but have managed to use putty to access and edit the asound.conf file, but nothing I have tried so far has worked. The Video either plays too fast or plays at correct speed but the audio device fails.

I would be really grateful if anyone could suggest any way of solving this problem, as, other than this openelec is absolutely perfect for my needs. I have tried running xbmc for windows on the revo's hdd and couldn't believe how laggy it was in comparison. openelec is far superior.


Re: Acer Revo R3700 sound problems. - therio - 07-14-2011

Hi there,

could you provide us the link that comes from the SSH command "aplay -l | paste"?


Re: Acer Revo R3700 sound problems. - banjo1891 - 07-16-2011

Hi therio

thanks for the quick response. The results of aplay -l and aplay -L are in the attached files. Hope you can make more sense of it than I can!
[attachment=246]aplay-L.txt[/attachment]

[attachment=247]aplay-l.txt[/attachment]


Re: Acer Revo R3700 sound problems. - therio - 07-16-2011

Hi,

inside XBMC- audiosettings, do the following:

optical/coax
DTS+
AC3+
Custom:
plughw:1,0
Custom:
plughw:1,0

Btw, you have a lot of "-sh: card: not found" in that last log!
Can you also post a dmesg log, to see what is going on?


Re: Acer Revo R3700 sound problems. - banjo1891 - 07-17-2011

[attachment=253]Dmesg.txt[/attachment]
Thanks a lot mate. That fixed it. I really appreciate the work and support you guys put into projects like this. A donation is on it's way!


Re: Acer Revo R3700 sound problems. - therio - 07-17-2011

Good to know it helped you Wink
About the log, no strange habits in there.. so I'll leave it for now.