OpenELEC Forum
[SOLVED] GT430 no Sound? - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: [SOLVED] GT430 no Sound? (/showthread.php?tid=8350)

Pages: 1 2 3 4 5


[SOLVED] GT430 no Sound? - Andro - 07-17-2011

So i've been searching for awhile now and cant get the sound working. I have run aplay -l and got this...

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

I then changed my /storage/.config/asound.conf to ...

Code:
pcm.!default {
type plug
slave {
pcm "hw:7,1"
rate 48000
}
}

still nothing. I also tried "hw:1,7" with no change.

Thanks for your help!


Re: GT430 no Sound? - Andro - 07-17-2011

correction, I just changed back to "hw:1,7" and no longer get the error message inside XBMC telling me the audio failed. don;t know how that helps me, but its a change.


Re: GT430 no Sound? - tom_say - 07-17-2011

try this and see if you get sound of the tv

speaker-test -c 2 -r 48000 -D hw:1,3

if that does not get you any sound then try

speaker-test -c 2 -r 48000 -D hw:1,7

if you get sound of the speaker let me know, that will be a good thing just means you have something wrong in your config setting


Re: GT430 no Sound? - Andro - 07-17-2011

tom_say post=8373 Wrote:try this and see if you get sound of the tv

speaker-test -c 2 -r 48000 -D hw:1,3

if that does not get you any sound then try

speaker-test -c 2 -r 48000 -D hw:1,7

if you get sound of the speaker let me know, that will be a good thing just means you have something wrong in your config setting

Ill try this once I'm home today. Once I SSH in and run as root user that's the only command line I need to use? How long will the test run?


Re: GT430 no Sound? - tom_say - 07-17-2011

you just need to hear sound out of the speakers if you do, then the rest should be easy to configure

i just realized speaker-test is not included in the build i can added it if needed what version of build are you using ? assuming generic build

but here is a quick round down of how to get sound going

aplay -l # will list sound card devices
for yours try looks like hw:1,3

for me i did not include a asound.conf i do not think it will be necessary follow the rest of the post and you should have sound if not let me know Smile


To enable HDMI audio out follow this steps:

First Login into OpenELEC box using ssh if using Linux

ssh username@ipaddress

example for us is
ssh root@192.168.1.XXX (where xxx is the ip of your box)

it will ask for a password type in:

openelec

Now we are login to our box

Config Files are located in .config so we need to change directory by type in:

cd .config

your prompt should show

root ~/.config #

Now we need to copy the sound.conf_ZBOX-HD-ID11.sample sound file from the modprobe.d.sample to modprobe.d folder type in:

cp modprobe.d.sample/sound.conf_ZBOX-HD-ID11.sample ./modprobe.d/sound.conf

we are now done with modprode.d and ssh type in:

exit

reboot openelec box

go over to your box and wait till its back up with this config about 15-20 sec

Within XMBC Navigate to the "System" "System" "Audio Output"

Under Audio Output select "HDMI"

Under Audio output device and passthrough output device select "custom"

for both custom settings type in:

plughw:1,3

you are done reboot system and enjoy HDMI audio


Re: GT430 no Sound? - Andro - 07-17-2011

i have both changed the sound.conf file using PuTTY as you suggested. no change

this is the file i copied over

Code:
# modprobe.d config for Zotac ZBOX HD-ID11
# This file is part of OpenELEC, many thanks to 'Dampfgarten'

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

now i really don't fully understand what I am up to here, but this doesn't look right.


Re: GT430 no Sound? - tom_say - 07-17-2011

that file might not be needed by you but for now leave it there, did you reboot the system ?

and did you change the setting within xbmc ?

after you reboot please post what aplay -l shows


Re: GT430 no Sound? - Andro - 07-17-2011

Code:
root ~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
root ~ #

yes i have reset

xbmc audio currently set

plughw:1,3


Re: GT430 no Sound? - Andro - 07-18-2011

Is there anything in the BIOS I need to change?


Re: GT430 no Sound? - therio - 07-18-2011

What options do you have for audio in the bios?