OpenELEC Forum
[SOLVED] GT430 no Sound? - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: [SOLVED] GT430 no Sound? (/showthread.php?tid=8350)

Pages: 1 2 3 4 5


Re: GT430 no Sound? - Andro - 07-21-2011

nothing... i did try 7,8, & 9

still getting the popup inside xbmc... failed to initialize audio device, check audio settings


Re: GT430 no Sound? - Andro - 07-21-2011

GPU

this is the graphic card I am using, any concerns there?

did i miss a step somewhere during downloading openELEC? do i need to manually download drivers or something?


Re: GT430 no Sound? - Andro - 07-22-2011

ok, im going the wrong direction here. while continuing to google and cus my way through this i must have broken something even worse.

now ...

Code:
root ~ # cat /proc/asound/cards
--- no soundcards ---
root ~ # aplay -l
aplay: device_list:240: no soundcards found...
root ~ #

how should i proceed? clean install?


Re: GT430 no Sound? - tom_say - 07-22-2011

andro,

since you are at that point try this out http://www.mediafire.com/?99v6uaw3yjcuo
they are the kernel and system files only difference is that it included speaker-test rename both files KERNEL SYSTEM and place them in the update folder of openelec

follow the steps i had post do not included the asound.conf at least not yet

now a couple of questions

do you have the computer directly connected to your monitor or do you have a switch/splitter/stereo if you do disconnect it and go direct from computer to monitor

print output of aplay -l and post after you do the upgrade that will help out to give me the card and device number for the next step

speaker-test -c 2 -r 48000 -D hw:X,X where X = the card and device number you get this will give you static coming out of the speakers everything works out well

if it does not ls -F /proc/asound/cardX where X= card number from aplay -l post that on the thread

we can go on from there when you post back


Re: GT430 no Sound? - Andro - 07-22-2011

Ill try this when I'm home! Thanks.

After I download those files what's the best way to put them in the update folder? Use the same tool I had previously used to edit asound.conf?

The computer is connected directly to my TV via HDMI.


Re: GT430 no Sound? - tom_say - 07-22-2011

same way

http://openelec.tv/installation/updating


Re: GT430 no Sound? - Andro - 07-23-2011

Code:
root ~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

Code:
root ~ # speaker-test -c 2 -r 48000 -D hw:1,3

speaker-test 1.0.24.2

Playback device is hw:1,3
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 1048576
Period size range from 32 to 524288
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 21.923205

no sound

Code:
root ~ # ls -F /proc/asound/card1
codec#1 eld#1.0 id



Re: GT430 no Sound? - tom_say - 07-23-2011

print out of

dmesg | grep HDMI or hdmi

also

cat /proc/asound/card1/eld#1.0

and

cat /proc/asound/card1/codec#1

you did remove / rename asound.conf at least for now ?


Re: GT430 no Sound? - Andro - 07-23-2011

Code:
root ~ # dmesg | grep HDMI
[ 13.343414] HDMI status: Pin=5 Presence_Detect=0 ELD_Valid=0
[ 13.384698] input: HDA NVidia HDMI/DP as /devices/pci0000:00/0000:00:02.0/000 0:01:00.1/sound/card1/input8

Code:
root ~ # cat /proc/asound/card1/eld#1.0
monitor_present 0
eld_valid 0

Code:
root ~ # cat /proc/asound/card1/codec#1
Codec: Nvidia GPU 14 HDMI/DP
Address: 1
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x10de0014
Subsystem Id: 0x10de0101
Revision Id: 0x100100
No Modem Function Group found
Default PCM:
rates [0x0]:
bits [0x0]:
formats [0x0]:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=0, o=0, i=0, unsolicited=0, wake=0
Node 0x04 [Audio Output] wcaps 0x72b1: 8-Channels Digital Stripe CP
Control: name="IEC958 Playback Con Mask", index=0, device=0
Control: name="IEC958 Playback Pro Mask", index=0, device=0
Control: name="IEC958 Playback Default", index=0, device=0
Control: name="IEC958 Playback Switch", index=0, device=0
Device: name="HDMI 0", type="HDMI", device=3
Converter: stream=6, channel=0
Digital: Enabled
Digital category: 0x0
PCM:
rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
bits [0xe]: 16 20 24
formats [0x5]: PCM AC3
Unsolicited: tag=00, enabled=0
Node 0x05 [Pin Complex] wcaps 0x407381: 8-Channels Digital CP
Pincap 0x09000094: OUT Detect HBR HDMI DP
Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
Conn = Digital, Color = Unknown
DefAssociation = 0x1, Sequence = 0x0
Pin-ctls: 0x40: OUT
Unsolicited: tag=05, enabled=1
Connection: 1
0x04

Yes, I have removed asound.conf.


Re: GT430 no Sound? - tom_say - 07-24-2011

For HDMI audio to work, both monitor_present and eld_valid must be 1

for some reason your monitor is not reporting the edid value correctly so you will not get audio

lets try this please edit modprobe.d/sound.conf and put a # in front of the last line that says options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2 and also print the output of

ls -F /proc/asound/cardX again thanks

cat /var/log/Xorg.0.0.log | paste

dmesg | paste

aplay -l
and paste the links

basically what you will have is a list of more hdmi devices after modify the sound.conf you can try them all with speaker-test -c 2 -r 48000 -D hw:1,X where X is the device number if you do get static sound from one of them use the card and device number within xbmc

good luck