OpenELEC Forum
[MSI CR-650 e350 Fusion Notebook] No Audio - Printable Version

+- OpenELEC Forum (https://forum.openelec.tv)
+-- Forum: Generic Forum (https://forum.openelec.tv/forumdisplay.php?fid=5)
+--- Forum: AUDIO (https://forum.openelec.tv/forumdisplay.php?fid=53)
+--- Thread: [MSI CR-650 e350 Fusion Notebook] No Audio (/showthread.php?tid=9315)

Pages: 1 2


[MSI CR-650 e350 Fusion Notebook] No Audio - vinzi - 08-05-2011

Hi all!

this is my first post on this forum.

I have a MSI notebook based on AMD E-350. I've installed the latest nightly build (7616) but the audio doesn't work. I haven't still tried if the audio works over HDMI , I will check later...

Could anyone help me?

Thanks!


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - newphreak - 08-05-2011

I'm pretty sure this config should help you.
Quote:pcm.!default {
type plug
slave {
# pcm "hw:1,0" #delete the first hash for sound over analog
# pcm "hw:1,1" #delete the first hash for sound over optical
# pcm "hw:1,1" #delete the first hash for sound over hdmi
rate 48000
}
}
Save that as asound.conf in Configfiles found on the samba share.
And remember to remove the hash for the output you want to use, then try the different options within xbmc to get sound.

If you need more explanation, just ask.

Edit: fixed typo


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - vinzi - 08-05-2011

thanks for your quick reply, I will try later that, but I have some question...

>Save that as asound.conf in Configfiles found on the samba share.

I need to connect the notebook via lan and found the file asound.conf in the share folder from another pc with Operating system?

>And remember to remove the hash for the output you want to use, then try the different options within xbmc to get sound.

what's the hash? Sad consider that I'm a dummy with linux and XBMCSmile

Excuse me for these stupid question but i'm a newbie...


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - newphreak - 08-05-2011

hehe, correct. You need need to access the notebook from another computer.

The hash is #.

so if you want analog, the asound.conf should look like this:
Quote:pcm.!default {
type plug
slave {
pcm "hw:1,0" #delete the first hash for sound over analog
# pcm "hw:1,1" #delete the first hash for sound over optical
# pcm "hw:1,1" #delete the first hash for sound over hdmi
rate 48000
}
}



Re: [MSI CR-650 e350 Fusion Notebook] No Audio - vinzi - 08-05-2011

Ok, now the menu sound works, but if i try to play any MKV Film I don't ear nothing and have the error "failed to initialize audio device check your audiosettings"

I'm using the analog audio and the audio output device is iec958...


p.s. It's very strange... When I reboot frome the XBMC after the sound don't works, If I shutdown and power up manually the notebook the menu audio works...


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - vinzi - 08-06-2011

OK, I've tried others audio output device like HDMI, HD ATI DEVICE etc.. but the audio for film, music doesn't work. If I select HDMI when I play a film can't get the error tab, but the audio don't work anyway...

Other thing, How I activate the HDMI output for video?

thanks


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - therio - 08-07-2011

hi, make it a custom output device for both, and in the textblock, place this for both:

plughw:1,0

Let us know if it helped.


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - vinzi - 08-07-2011

Hi!

I need to specify this in the XBMC?

SYSTEM>SYSTEM>Audio Output>Custom Output?

or i need to replace pcm "hw:1,0" in the asounf.conf file?

thanks.


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - vinzi - 08-07-2011

I'm making progress, now I have audio over Notebook speaker if i use these setting on the asound.conf file:

pcm.!default {
type plug
slave {
pcm "hw:1,0" #delete the first hash for sound over analog
# pcm "hw:1,1" #delete the first hash for sound over optical
# pcm "hw:0,3" #delete the first hash for sound over hdmi
rate 48000
}
}

If I remove the hash to use HDMI the audio works olny over HDMI...


Currently the only way that I have to run different audio output is to change each time the configuration file.

The ideal way would be that the notebook speakers are turned off when I connect the HDMI cable... It's possible?


Re: [MSI CR-650 e350 Fusion Notebook] No Audio - therio - 08-07-2011

The notebook speakers can't be turned off automatically yet with this configuration. I already have tried such options with the asound.conf, but as I'm not that good known with alsa, this still needs some time. If anyone else has ideas about that, please let me know. The setup for xs35gt contains a configuration that sends audio to more than one output at the same time. It is no solution yet, but a start for further configuration Wink